Jump to content
Flirc Forums
eskro

[Windows] How to make your PC SLEEP/WAKE by pressing a button on your Remote

Recommended Posts

How to make your PC SLEEP/WAKE by pressing a button on your Remote? (Windows Only)

if you want to make your PC SLEEP/WAKE using a button on your remote, this is easy,,,

first disable the hibernate feature on your PC

1. type CMD in Start menu search box area and then hit Ctrl + Shift + Enter

2. try/type either of these 2 commands here and then hit enter: powercfg /hibernate off or powercfg -h off

3. hibernate should be OFF now...

then follow these steps to create a windows shortcut that would make your HTPC sleep when double-clicking on it

A ) Right click on a empty area on desktop, and click on New and Shortcut.

B ) Type rundll32.exe powrprof.dll,SetSuspendState into the location area, and click on the Next button

C ) Type Sleep for the name, and click on the Finish button (You can name this anything you would like though)

Now Important, if you want to move your shortcut elsewhere, do it now!

Ok so, once moved to where you want it, right-click on it,

then assign a keyboard shortcut to it, example, CTRL + ALT + S

refer here if you have problems doing so

http://thecustomizew...with-windows-7/

then, using FLIRC's GUI, select the FULL KEYBOARD controller for a sec,

click on CTRL + ALT + S, so that those 3 keys appear in green on your screen

and then record this key combination to your desired button on your remote...

Now, if all goes well, when you'll press that recorded button on your remote,

it'll emulate like if u would press CTRL + ALT + S on your keyboard

and this means windows will go to SLEEP!!

Night Night :)

  • Like 1

Share this post


Link to post
Share on other sites

once the computer is asleep, and you have wake enabled on usb in device manager and in bios, will the same key combination wake the computer too? so if this is assigned to my harmony as power toggle, it can sleep and wake the computer?

or does the ctrl/alt mess up wake on keyboard?

Share this post


Link to post
Share on other sites

Sorry to bounce you around threads but waking FLIRC is still in beta (have you got this firmware?). So i believe you should be able to.

Share this post


Link to post
Share on other sites

eskro nice tips, thank you..but i just want to add something happened to me..

for win7 64 you need to have the top rights : first as admininistrator , second : even as inside an administrator group; you dont have the all permition into the system32 . so you need to manually change ; point to rundll32.exe - right click - security tab - advance:

1) change the " OWNER " to you..( all system installation on win7 by default created -"TrustedInstaller " user as owner ) with full control..dont delete the user , just change the top comannd lien to your user..

2) add all permitions pointing your admin user name. and save

3) go out and in again and double check that you are the MAN..in the list

after i did this .. my " SLEEP " shortcut works perfect..

by the way : make your backup or system restore point before change something inside the win7 64- system32 ..in that way you dont need to cross the fingers..and i dont want to give you a wrong path for screw up your system ..

that is a great forum very instructive ..

and the FLIRC is a rockkkk !!... thanks Jason

good luck all :)

Share this post


Link to post
Share on other sites

I could put together a similar guide for Linux users if there's demand for such a thing...

I would definitely appreciate it, since I just purchased two of these to replace MCE remotes for XBMCbuntu systems that I have been struggling with to get everything working correctly.

Share this post


Link to post
Share on other sites

Well, I was all set to write such a thing, but I'm still having trouble with wake using Flirc with XBMCbuntu. I got suspend working correctly from the command line and I can wake it by enabling wakeup on the proper USB bus, but whenever I plug a Flirc into a port on that bus, the machine wakes immediately after I suspend it. Jason is working on another approach for sleep/wake on Linux machines, so as soon as a version of Flirc firware is available that behaves as expected, I'll document everything I've tried so far.

Share this post


Link to post
Share on other sites

Well, I was all set to write such a thing, but I'm still having trouble with wake using Flirc with XBMCbuntu. I got suspend working correctly from the command line and I can wake it by enabling wakeup on the proper USB bus, but whenever I plug a Flirc into a port on that bus, the machine wakes immediately after I suspend it. Jason is working on another approach for sleep/wake on Linux machines, so as soon as a version of Flirc firware is available that behaves as expected, I'll document everything I've tried so far.

Thanks for the update.

Share this post


Link to post
Share on other sites

HI Guys im new here :)

i have conf my Flirc , works pretty nice , now i have create sleep / awake ..... the part how goes sleep works, but awake works not;( , whois my error :(

i have try this step

if you want to make your PC SLEEP/WAKE using a button on your remote, this is easy,,,

first disable the hibernate feature on your PC

1. type CMD in Start menu search box area and then hit Ctrl + Shift + Enter

2. try/type either of these 2 commands here and then hit enter: powercfg /hibernate off or powercfg -h off

3. hibernate should be OFF now..

but he say i have no acces for change , i dont no is important or not .. my problem is only awake ;) need help many thx

i know my english is crap i hope u have all understanding :)

greetz

EDIT works now all ;)

Share this post


Link to post
Share on other sites

Any idea why this isn't working for me? I made the shortcut and moved it to the Documents folder where I want to keep it. When I double click on the shortcut the computer goes to sleep. So I know the shortcut works.

I right clicked on it and set the shortcut to Ctrl+Alt+S and when I press that on the keyboard nothing happens...

I don't understand why it isn't working I have XBMC set up to use Ctrl+Alt+x and that shortcut works fine, but the one for sleep won't do anything.

Any ideas?

I'm on Windows 7 32 Bit btw

Share this post


Link to post
Share on other sites

I am back using my MCE remote + hamony One as i can not use flirc to wake or shutdown WIn 7 64bit XBMC pc... The short cut i made works but the remote button doesnt work... I have tried a few things and am on the lastest firmware V6..

Shame is it is a great product with xbmc...Until this is part of the software and firmware i cant us eit on my main HTPC...

Share this post


Link to post
Share on other sites

@furnbird Try to use autohotkey script, this is what I use here:

;Sleep system: (ctrl+shift+f11)

^+F11::

  DllCall("PowrProf\SetSuspendState", "int", 0, "int", 0, "int", 0)

  return

Share this post


Link to post
Share on other sites

Running Win7: I've got a remote button mapped to the 'Sleep' shortcut, and it works great...as long as I leave the shortcut on my desktop. Even if I move the shortcut file to another folder BEFORE assigning a keyboard shortcut, machine will not sleep on remote press. Wake button works great with FW v6.

I'm happy it's working, but I love a clean desktop. Any ideas?

Edit: I can hide the shortcuts on the desktop by making them 'hidden' and then telling Windows not to show hidden files. A little inconvenient as I like to have ready access to Windows' hidden files/folders.

Share this post


Link to post
Share on other sites

My remote will only put my pc in sleep stage, but will not wake it up. Is there anything else i can try.I hit ctrl-alt-s on the keyboard it wakes up

Share this post


Link to post
Share on other sites

I am also trying to get Flirc to allow the PC to wake. I have located the device in the device manager, under libusb (Win USB) devices, listed as flirc. However, there is no power management tab so I cannot allow it to wake the computer :(

Does anyone know why it does not have the power management tab? or perhaps how to give it the tab?

Share this post


Link to post
Share on other sites

Does it take a long time

My remote will only put my pc in sleep stage, but will not wake it up. Is there anything else i can try.I hit ctrl-alt-s on the keyboard it wakes up

Also does it take a long time for the pc to come out of sleep? It goes to sleep very fast.

Share this post


Link to post
Share on other sites

Hi All,

Tried this on my new Win7 HTPC and it works to put the machine to sleep. I did have one issue whereby you need to put the shortcut somewhere in the users Start Menu folder structure (otherwise it doesn't work). I found that answer somewhere on the net.

Now the problemm is, I can't get Flirc to wake it back up. I think the root cause of this is that the keyboard it presents to the Windows OS doesn't have a power management tab (as mentioned previously), I've googled it a bit and it would seem that it's a driver\device issue given that most of the responses to fix it are to update\reinstall drivers, but these are on normal keyboard devices.

Does anyone else have a Power Management Tab on their Flirc keyboard device?

Share this post


Link to post
Share on other sites

Hi everyone, I can't seem to get the power off to work with the ctrl+alt+s shortcut when I'm in XBMC. It works when I'm on the desktop. I have it on Windows 8.

I had to put a link on the taskbar and use the Windows button + 2 to launch the link. The issue is that when I do it this way upon wakeup the xbmc is no longer selected in the taskbar and the remote no longer controls Xbmc.

Does anyone know how to set this up properly?

Share this post


Link to post
Share on other sites

You could map a button to alt+tab (I think that's the shortcut to switch apps). Then you can switch to XBMC.

Share this post


Link to post
Share on other sites

yeah worked great for sleeping which is cool, 1 more awesome thing flirc can do! But all i wanna do is wake from usb and there is no power management tab for this device's properties in device manager. I really think thats the problem here.

 

im using win7, asus p8z77-m ivy bridge core i3

 

by the way one guy asked how to hide the icon all you have to do is change the icon to a blank icon in the default windows collection. which is located at C:\Windows\System32\shell32.dll just right click the icon and go to properties and then change icon.

 

You can get ultimate windows tweaker for windows seven to disable the shortcut little arrow.

 

I think there is something you can change the name of a icon to, like blank, or null to make it disapear, you would have to google that. It's a secret

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×