Jump to content
Flirc Forums
baj1

flirc only sending every-other remote command?

Recommended Posts

Hello All,

 

I got my first flirc (first two) in the mail today.  The first one is for my HTPC (Windoze 7 Pro SP1).  I'm running NextPVR and didn't have a working IR input for my Hauppauge 45 button remote.  It was no problem to set up, the software works well (although a little time consuming).  It seems that all the remote keys are working as I programmed them, to replicate the keystrokes used by NPVR.  The trouble is it's only passing every-other remote command through to NPVR.  I have to hit every remote button twice to get the response of one from the software. At first I thought I was pressing the remote buttons to fast, but I tried waiting over 10 seconds between presses, it didn't matter, it was still only sending every-other button press.  My actual keyboard works fine with NPVR (how I have been using it so far).  I saved my config and created a simple Minimalist config with the same remote that I tested with Win-dohs Media Center, which yielded the same every-other result.  I've attached my files for both the NPVR config and the minimialist config, if that helps.

 

Any thoughts?

 

Thanks,

-Brad

H45_minimalist_flirc_config.fcfg

H45_NPVR_flirc_config.fcfg

Share this post


Link to post
Share on other sites

I'll have a fix for this, in the mean time, record every button twice. This is due to the particular remote protocol.

 

Thanks Brad.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jason!  Should I look for the fix in this thread or do routine checks for new firmware?

 

Also, please let me know if I can be of assistance in testing the fix.

Share this post


Link to post
Share on other sites

Just curious, do you know if this fix was completed?  I had been using a different remote but decided to give the Hauppauge 45 button a try again.

 

Thanks,

-Brad

Share this post


Link to post
Share on other sites

Just curious, do you know if this fix was completed?  I had been using a different remote but decided to give the Hauppauge 45 button a try again.

 

Thanks,

-Brad

Hey Brad - 

I've got a new firmware image that's in the beta release section of the firmware. While the easiest work-around is just to record every button twice sequently, with my new algorithm I will be able to at least detect this kind of remote and prompt the user until I figure out a way to determine what the second press is without the user pressing it.

Share this post


Link to post
Share on other sites

Hey Brad - 

I've got a new firmware image that's in the beta release section of the firmware. While the easiest work-around is just to record every button twice sequently, with my new algorithm I will be able to at least detect this kind of remote and prompt the user until I figure out a way to determine what the second press is without the user pressing it.

 

 

I have a Hauppauge 43 (not 45) button remote (A415) and I have the same problem, I have to record every button twice to make it work correctly, but the program does not prompt anything. I guess that all similar hauppauge remotes have the same problem...

Edited by alpianon

Share this post


Link to post
Share on other sites

I haven't quite built in support for prompting the user yet. I'm in the middle of fixing up my build scripts so I can finally get the linux release version caught up. Just released the 64 bit, now scratching my head over the 32 bit version...

Share this post


Link to post
Share on other sites

This fix got lost somewhere along the way.  I just reconfigured a Hauppauge 45 button remote on the latest Flirc s/w (v3.25.3) and the latest f/w in my gen1 Flirc (v3.11.0).  Same issue as 7 years ago, the Flirc is only sending every-other button press to Kodi (have to hit each remote button twice to do anything).  The temporary fix of hitting each remote button twice during setup doesn't work anymore, the software saves the first press before I can hit the button on the remote a second time.  I tried many times to be fast enough on the buttons, I'm not.

Edited by baj1
added text for clarification

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...