Jump to content
Flirc Forums

FLIRC + Harmony + Ropieee XL Endpoint


bl4scott
 Share

Recommended Posts

I have recently purchased FLIRC and having issues right out of the gate.  I have the software installed and the firmware updated.  

  • Pull FLIRC into PC
  • Controller: Media Keys
  • Attempted to Record Logitech Remote 
    • Play/Pause, Forward, Backward (Most time I get an error after the first record that the button has already been mapped)
    • Saved Configuration
  • Unplug FLIRC
  • Plug FLIRC into Ropieee XL Endpoint
    • Validated Ropieee shows up within settings
  • Add Roon Control Zone to Ropieee XL settings (copied from Roon)
  • Run Harmony App
    • Add new device
      • Entertainment
      • FLIRC / KODI
      • Save / Sync Settings
  • Run Roon
    • Settings / Extensions / Enabled
  • Attempt to use remote to Fast Forward Song
    • FAIL

 

image.thumb.png.ab454ed1b2f1544b61a99b0a04becb77.png

Any help would be appreciated.

 

Brian 

image.png

Link to comment
Share on other sites

There is a whole lot in here I don’t understand. 
 

flirc just translates remote buttons as keyboard keys. If a keyboard works, flirc will work. 
 

try a keyboard. If that doesn’t work, something is wrong. 
 

I don’t understand the need to setup flirc and then set it up again a second time ( the first manually recording and the second with harmony). What am I missing?

Link to comment
Share on other sites

Thank you for the reply Jason.

 

Are you familiar with Roon? I am trying to use my Harmony remote to pause, FF, and go back songs.  That's all. I am only setting up flirc once, recording "space bar, ctrl-K and ctrl-J.

I tried setting up the keyboard and was able to record ctrl-k but when I try ctrl-j and space bar I get this:

image.png.8f3463d0b14163f99310b0f11480b722.png

 

Edited by bl4scott
Link to comment
Share on other sites

I’m sorry, what is the ‘core’? Can you send me a direct message, and we can do a chat session so I can help you more in real time. I’m sure this is frustrating, and I’m sorry. It’s just me, and I can’t get anyone to the office to help me because of the pandemic, and I’m overloaded with a ton of bullshit work that eats most of my day.

Link to comment
Share on other sites

  • 10 months later...

In case anyone else runs into this problem, a solution to try is to use a zone name that doesn't contain spaces.  Right after renaming my zone in Roon from two words with a space in between to one word and then updating the name in Ropieee, I was able to use the media buttons (Play, stop, Next, Prev).  The commands started working without a reboot of Ropieee (of course I did eventually).  I think this is a matter for the Ropieee author and in the threads where I've seen people post about issues like ours I don't see anything about a solution or mention of the zone name format.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...