Jump to content
Flirc Forums
digitalfrog

Flirc dongle disconnects when playing music !

Recommended Posts

Well, that's a weird one.

Raspberry 4, Flirc v2 (4.9.3)

Flirc app 3.25.3 sees the flirc dongle, can program it etc... The second I play a track (mpd) the gui shows disconnected and freezes. I stop playing the music, and after a few seconds the guy becomes responsive again.
Same from command line (after quitting the GUI just to be sure). flirc_util commands are working fine, but if I play a track: "device disconnected, can't run command"
The Raspberry pi 4 is attached to an external USB DAC. I initially thought a USB power issue and bought the official raspberry wall unit but it did not solve the problem.

Sadly the logs say little. THis is when I plug the flirc:

 

Jun 17 21:57:54 raspberrypi kernel: [ 1530.238733] usb 1-1.3: new full-speed USB device number 11 using xhci_hcd
Jun 17 21:57:54 raspberrypi kernel: [ 1530.379765] usb 1-1.3: New USB device found, idVendor=20a0, idProduct=0006, bcdDevice= 2.00
Jun 17 21:57:54 raspberrypi kernel: [ 1530.379781] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jun 17 21:57:54 raspberrypi kernel: [ 1530.379793] usb 1-1.3: Product: flirc
Jun 17 21:57:54 raspberrypi kernel: [ 1530.379806] usb 1-1.3: Manufacturer: flirc.tv
Jun 17 21:57:54 raspberrypi kernel: [ 1530.394739] hid-generic 0003:20A0:0006.000A: hiddev96,hidraw1: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:01:00.0-1.3/input0
Jun 17 21:57:54 raspberrypi kernel: [ 1530.405952] input: flirc.tv flirc Keyboard as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:20A0:0006.000B/input/input9
Jun 17 21:57:54 raspberrypi kernel: [ 1530.469246] input: flirc.tv flirc Consumer Control as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:20A0:0006.000B/input/input10
Jun 17 21:57:54 raspberrypi kernel: [ 1530.469646] input: flirc.tv flirc System Control as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:20A0:0006.000B/input/input11
Jun 17 21:57:54 raspberrypi kernel: [ 1530.470106] hid-generic 0003:20A0:0006.000B: input,hidraw2: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-0000:01:00.0-1.3/input1
Jun 17 21:57:54 raspberrypi kernel: [ 1530.479915] hid-generic 0003:20A0:0006.000C: hiddev97,hidraw3: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:01:00.0-1.3/input2
Jun 17 21:57:54 raspberrypi mtp-probe: checking bus 1, device 11: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3"
Jun 17 21:57:54 raspberrypi mtp-probe: bus: 1, device: 11 was not an MTP device
Jun 17 21:57:54 raspberrypi mtp-probe: checking bus 1, device 11: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3"
Jun 17 21:57:54 raspberrypi mtp-probe: bus: 1, device: 11 was not an MTP device


There are no new log entries as I start/stop the music and get the disconnect/reconnect.

Not sure what to do ....
 

Share this post


Link to post
Share on other sites

So apparently if I do a mpc toggle to stop the music, send the volume up/down IR code for instance and mpc toggle to carry on playing it will work but having the music interrupted each time I change the volume is not ideal.

Nobody else went through this issue ? No fix ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...