Jump to content
Flirc Forums
Adri

Flirc not working after upgrade to 3.25

Recommended Posts

1 minute ago, Chizad said:

After multiple rounds of unplugging and replugging in FLIRC, and closing out and reopening the software, it looks like the automatic firmware update worked. The FLIRC commands, still do not.

Eh...disregard this. I tried to manually upgrade, still got the same error. Closed out and back in the FLIRC software and still getting automatic upgrade attempts that fail. Will update the .ini now.

Share this post


Link to post
Share on other sites

Dear jason, thank you for the quick help!

I had the same problem, same Windows & Harmony 650, w/ dori SKU.

It now works with the files you have published, thank you for that!

[sighs relief]

Share this post


Link to post
Share on other sites

It won't let me copy or save the log to a file. All those options are grayed out.

But it doesn't say much. Just that it's GUI version 3.25.0, Windows OS, ***Device Disconnected***

***Device Connected***

Firmware Version:4.9.0

SKU: Flirc 2.0 [dori]

Git Hash 0x5bc57f10

ERROR. Firmware upgrade required. (fw >=4.1.0)
***Device Disconnected***

Share this post


Link to post
Share on other sites

Hi @jason

Thank you for your support.
The update to 4.9.1 with the dori file went trough without a issue.
Loaded my config afterwards. 

But still no reaction from the FLIRC when it's connected to my Sunrise TV UHD.

Share this post


Link to post
Share on other sites
11 minutes ago, PeterHomoki said:

Dear jason, thank you for the quick help!

I had the same problem, same Windows & Harmony 650, w/ dori SKU.

It now works with the files you have published, thank you for that!

[sighs relief]

Well dang! What am I doing wrong?

Share this post


Link to post
Share on other sites
2 minutes ago, Chizad said:

Are you guys on Nemo? I'm on Dori.

If you did the flirc.ini changes, a flirc.log file should have been created and put on your desktop, do you see that?

Share this post


Link to post
Share on other sites
11 minutes ago, jason said:

If you did the flirc.ini changes, a flirc.log file should have been created and put on your desktop, do you see that?

Sorry, I didn't know to look for it. Now that I do, it's too large to upload or even to paste here. Any suggestions?

Share this post


Link to post
Share on other sites

  

4 minutes ago, jason said:

Did your remote work with the previous firmware?

Yes before today i was using Firmware 4.4.2 with my Harmony Hub.
And I have also 2 other Flirc v2 with the same config still on 4.4.2 and both are still functional.
I wanted to try a new config for Shield TV and for that i had to install a new config, during this i also updated the firmware to 4.9.0 and since then nothing goes

Edited by AcIvI
added the quote

Share this post


Link to post
Share on other sites
5 minutes ago, AcIvI said:

  

Yes before today i was using Firmware 4.4.2 with my Harmony Hub.
And I have also 2 other Flirc v2 with the same config still on 4.4.2 and both are still functional.
I wanted to try a new config for Shield TV and for that i had to install a new config, during this i also updated the firmware to 4.9.0 and since then nothing goes

did you re-learn your keys?

Share this post


Link to post
Share on other sites
5 minutes ago, jason said:

did you re-learn your keys?

I did only reload the configfile. No way to re-learn, because the original remote is Bluetooth.
I used the config file that worked before.

Share this post


Link to post
Share on other sites
14 minutes ago, AcIvI said:

I did only reload the configfile. No way to re-learn, because the original remote is Bluetooth.
I used the config file that worked before.

Wait. Flirc can’t work with Bluetooth, I’m not following?

Share this post


Link to post
Share on other sites
9 minutes ago, jason said:

Wait. Flirc can’t work with Bluetooth, I’m not following?

The Original remote is BT, but the device works with a IR Dongle, that's the reason why i'm using Flirc.

I used this thread for instructions:

 

Share this post


Link to post
Share on other sites
7 minutes ago, AcIvI said:

The Original remote is BT, but the device works with a IR Dongle, that's the reason why i'm using Flirc.

I used this thread for instructions:

 

You can't just re-load the configuration file. Re-learning the keys is necessary because I'm using new USB codes. I've edited your config file. Load this up and try that.

Sunrise_Flirc.fcfg

Share this post


Link to post
Share on other sites
1 hour ago, jason said:

You can't just re-load the configuration file. Re-learning the keys is necessary because I'm using new USB codes. I've edited your config file. Load this up and try that.

Sunrise_Flirc.fcfg 348 B · 0 downloads

Thank you. Did not know this detail.
Unfortunally it still does not work.
Is there a way to downgrade back to 4.42, just to be sure that the Flirc still works?

Also if i clear the configuration, do i need a configuration for a shield tv 2017? That would be also a way to test if it still works. Because that is that what i wanted to test before buying another flirc for the shield.

Share this post


Link to post
Share on other sites
2 hours ago, AcIvI said:

Thank you. Did not know this detail.
Unfortunally it still does not work.
Is there a way to downgrade back to 4.42, just to be sure that the Flirc still works?

Also if i clear the configuration, do i need a configuration for a shield tv 2017? That would be also a way to test if it still works. Because that is that what i wanted to test before buying another flirc for the shield.

Oh I'm so sorry, I modified the content and forgot to update the CRC. Try the attached.

Sunrise_Flirc_updated.fcfg

Share this post


Link to post
Share on other sites
12 minutes ago, jason said:

Yeah. Have you tried restarting or using a different USB port? We can do a team viewer session

Sorry, I somehow missed your request for a team viewer session, but after seeing your last message, I did reboot and was able to install the new firmware successfully, and I'm good to go!

Thanks so much for your help and quick responses!

Share this post


Link to post
Share on other sites

Hi Jason,

I did the software update, and the firmware upgrade. After that, I cleared the configuration of my flirc device and re-programmed some keys. However, the flirc still does not accept any of the commands from my Harmony remote.

So, it seems for me the issue is not solved yet. Do you have any ideas left?
I suppose a downgrade to the last version before 3.25 would do the job.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...