Jump to content
Flirc Forums
tj147

Updated Flirc software and now it doesn't work

Recommended Posts

I loaded up the Flirc software for the first time in a while and it said there was an update available. I thought it couldn't hurt to update it, but it turns out it can. Ever since I updated it, my Logitech Harmony 650 remote doesn't work at all with it. It says it's connected on Flirc. When I open up the program and press buttons on my remote, the keys that are pressed aren't showing that they're being pressed but I can tell that it's being read by Flirc because it will say things like "recorded successful," "that button already exists," and "button erased" whenever I press a button on my Logitech. Even after clearing the configuration and mapping out new buttons, the remote can't control anything and they aren't showing in the program.

I've uninstalled and reinstalled Flirc, updated both the GUI and Firmware (v3.25 GUI and 3.11 firmware), tried to manually install driver and used the ZADIG program (installation failed), deleted and readded Flirc on the MyHarmony App and I've restarted my computer multiple times. I'm using Windows 10 and I bought Flirc off Amazon several years ago so it's probably Gen 1.

Share this post


Link to post
Share on other sites

Hi,

I have the very same problem. I have the flirc streamcom edition and noticed today that there was a new firm version. After updating it the flirc keyboard presses don't work. Flirc seems to be connected with the flirc software as I can record presses, but they don't work on windows 10.

 

Share this post


Link to post
Share on other sites

I've been troubleshooting a little bit. the power button works (I have the streacom edition). So it seems the flirc hardware is catching the ir commands fine from the remote. I can also record keypresses. The problem seems to be that windows 10 is not recognicing flirc as a keyboard device, so the remote key presses aren't treated as keyboard keypresses.

Share this post


Link to post
Share on other sites

Hi again,

I've been troubleshooting a bit more. The problem seems to be on the flirc interface 0 driver. It gets recogniced as and USB input device, but it throws and error 10:

 

This device cannot start. (Code 10)

An unknown item was found in the report descriptor.

Share this post


Link to post
Share on other sites

Yes I also see a flirc interface 0 in the Zadig program I downloaded. I can replace the driver for interface 0, the current driver is: HidUsb (v10.0.18362.175)

 

 

Zadig.log

Edited by tj147
Adding log

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...