Jump to content
Flirc Forums

Record yes, playback no, Windows 10

Mombassa Jesus

Recommended Posts

I've installed the FLIRC drivers on a Windows 10 system (1903) and plugged in the device.  I am attempting to use an RTI RP6 to send it infrared commands.

The learning mode works fine. I bring up the keyboard controller, tell it I want to program the spacebar, press a button on the remote, that triggers the RP6 to send infrared to the FLIRC, and yes it has recorded.

Nothing I do, however, seems to make it play back that space key press.  It seems to me that I should be able to go into any textbox (a browser address box, for example, or a command prompt), press the remote key, and see a space typed there. Is that a valid test?

And of course it does not strike the spacebar in Windows Media Player (which should jump to the next song).

I have tried both JVC infrared commands and Samsung TV commands, but the record-but-don't-play issue persists.

From reading other support on this issue it seems the usual recommendation is to just keep trying different sets of infrared commands from different possible remotes until it finally works. I guess I could do that, but it seems a bit too trial-and-error and I've already had two failures.  Is there anything else to try besides that?


Link to comment
Share on other sites

A little more fooling around with this and I have graduated from "never works" to "works inconsistently".  I had put the IR emitter right onto the FLIRC and it may not have liked that.  I've tried backing it off a bit and now get inconsistent results. The IR was originally firing at 38.3 KHz.  I tried changing it to 38, 37, no difference.  I tried increasing the repeats from 2 to 5, and decreasing them to 1.  No difference.  I'm not sure what else I can vary to try to lock this in.

Also, the software has a terrible message that needs to be changed. When you erase a key the message that pops up is something like "Key has already been erased", which makes it sound like you had already done it.  In fact, the software MEANS "Key has been erased", in other words, that you were successful.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...