Jump to content

Charter Cable remote works great if....


greenep48
 Share

Recommended Posts

After much learning and help from Chris!, I am happy to report that my Charter Cable system remote, made by Universal Electronics (see attachment), works like a champ to control XBMC using FLIRC. This remote is a little unique from the Harmony in that there is a master System Power button that cycles through all the devices for turn-on or turn-off - very handy. The issues to be resolved to get this bad boy to work may be common to lots of other cable and satellite remotes, so hopefully this helps others:

1) My Win7 HTPC has a DVD player installed, so I assigned XBMC to the DVD mode. Different device or mode selections on these remotes can behave differently, so be sure to read your remote manual carefully!

2) By default, this remote control's channel control capabilities are locked to the cable converter mode CBL. The affected keys are 1 through 0, CH+, CH-, and LAST. Deactivate this feature to allow programming these keys to other modes or devices for XBMC.

3) By default, this remote control's volume control capabilities are locket to the television mode TV. The affected keys are VOL+, VOL-, and MUTE. Deactivate this feature to allow programming these keys to other modes or devices for XBMC.

4) The operation of the Power/System Power buttons is dependent on the hardware features of your HTPC.

a] Power-down: Every HTPC will have the capability to shutdown the computer from XBMC by programming the remote's mode select button (DVD in my case) to the keyboard END button. Power-down is then activated by selecting the mode on the remote then activiating the POWER button as an XBMC computer shutdown command.

b] Power-on: Most HTPC systems do not have the hardware capability to do a true power-on from the remote. At best, you can set the HTPC to go into SLEEP mode on shutdown so that the USB ports remain functional and the HTPC can awaken on a subsequent power key command from the remote. SLEEP mode can sometimes be flaky - I have seen lots of spontaneous restarts from SLEEP mode. In my case, I have a cabinet fan powered from a USB port, so the SLEEP mode doesn't turn it off. I have to do a complete shutdown and use the front panel button to turn on the HTPC. Other solutions exist - search the FLIRC forums for some interesting fixes. Power-on and automatically run XBMC usually requires putting an XBMC shortcut in the HTPC Startup directory (see MS Win7 Help for directions). You should add some delay to the XBMC shortcut to be sure the HTPC is completly booted and stable before XBMC is started - not doing so can result in odd behavior from the remote and XBMC. Search the XBMC forums for more information. In my case, I needed to add 25 seconds to be sure the wireless network was connected and stable. The resulting shortcut command was everything within the brackets including all punctuation ["C:\Program files\XBMC\XBMC.exe" -d 25].

5) FLIRC keystroke entry: For some unknown reason, my HTPC system required that the remote send a repeat of each key code for XBMC to recognize the command. The ability to do this in FLIRC is not well documented but works well when implemented (thanks to Chris! here). It turns out that you can repeat the key programming at least twice in sucession for each remote button (and sometimes more, it seems), and FLIRC will dutifully send the sequence when you activate the button. Two programming cycles for each button did the trick on my system.

Hope this helps!

post-1540-0-24833900-1346560166_thumb.jp

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...