Jump to content
Flirc Forums
bugmenot

Flirc presses keys without me using the remote

Recommended Posts

This is fairly old topic, but I just noticed something that may be interesting to others.  I was having all sorts of trouble with phantom keys on my Macbook Pro (2010 model), both with and without noise cancellation, and I noticed that it only happens when I have the power cord plugged in to the laptop.  Even in a dark room, I get phantom keypresses if power is connected.  When I disconnect power (run on battery), I stop getting phantom keys even in a reasonably bright room.

 

I saw that it got better when I relocated my laptop to a different space earlier this week, but I didn't make the connection to the power supply until now.

 

Rob

  • Like 1

Share this post


Link to post
Share on other sites

i'm having issue as well mostly using the directional arrows.  making navigation through XBMC annoying.  

 

I upgraded to the latest release GUI and firmware.  GUI 1.2.2 and Firmware V2.3.

And I just tried running the command from the CLI to enable noise canceling and got this message:

 

Warning: cannot open USB deviceenabling noise canceler

 

any idea what that might mean?

Share this post


Link to post
Share on other sites

so a thought occurred to me after reading about the physical modifications made to add a filter in front of flirc.  

 

All my HTPC components are inside a cabinet with a clear glass/plastic door.  I wondered if the IR signal may be getting reflected around inside the cabinet and the same IR code picked up multiple times.

 

So i pulled off the child-safe-lock and opened up the cabinet and moved flirc outside the cabinet ( I Have it connected to a laptop with a 2 foot USB extender) and voila no more repeated key presses.

 

Unfortunately with 2 active babies i can't leave it like that, but maybe i can find some material to build a filter and it will work properly inside the cabinet like the other IR devices inside do.

Share this post


Link to post
Share on other sites

I added a second 2 foot USB extension  cable and ran my flirc out the back of my cabinet and it is now perched atop my center channel speaker.  It's been chilling out up there  for a week now and i haven't had a single issue of multiple key presses!  I'd prefer to have it inside behind the glass, but i don't have any spare material to use as a filter.

Share this post


Link to post
Share on other sites

I added a second 2 foot USB extension  cable and ran my flirc out the back of my cabinet and it is now perched atop my center channel speaker.  It's been chilling out up there  for a week now and i haven't had a single issue of multiple key presses!  I'd prefer to have it inside behind the glass, but i don't have any spare material to use as a filter.

Any chance I could you post a picture of your cabinet?

Share this post


Link to post
Share on other sites

So pictures are more important than a buggy Flirc () ... I think i should post that on Amazon ... -.-

I mentioned this in a few places, but don't like to because it doesn't excuse much, but it's just me here. I do everything, support, development, sales, packaging, testing, assembly, you name it. It's literally enough jobs for 2 people full time, and I do it outside a full time job. I may miss an occasional post, which I did, and I really apologize. One way to get a hold of me is by going to that contact support site, it goes directly to my email and is managed by zendesk so I don't lose track. I'll respond about what your specific problem is in your thread.

Share this post


Link to post
Share on other sites

I actually toyed with the idea of the IR plastic, but the product was absolutely atrocious. It scratched easily, and ended up looking purple. I'm going to see what I can do about this, it seems to trouble several people.

Share this post


Link to post
Share on other sites

Add me to the list of problems, started out working fine. Now i get random key presses, had to clear the config just to be able to use XBMC.

 

Whats the latest on this situation? I was going to update firmware but apparently I need to manually add the file and I cant find it anywhere.

Share this post


Link to post
Share on other sites

manually add the file?

 

I pushed an updated gui, the firmware is embedded in the GUI. Go to file->advanced. Hit force firmware upgrade.

 

That should get you on the latest.

Also, the commandline utility has some tools to help identify noise.

 

flirc_util settings

 

that will print out all the keys, any duplicates are sources of noise. I'll bring this to the GUI eventually.

Share this post


Link to post
Share on other sites

manually add the file?

 

I pushed an updated gui, the firmware is embedded in the GUI. Go to file->advanced. Hit force firmware upgrade.

 

That should get you on the latest.

Also, the commandline utility has some tools to help identify noise.

 

flirc_util settings

 

that will print out all the keys, any duplicates are sources of noise. I'll bring this to the GUI eventually.

I did some more fiddling last night and discovered that there is something going on during reboots that is messing up my flirc.

 

If I go to a windows PC and clear config, then reprogram I can plug it into my XBMC (openelec) and it will work fine, however after a reboot the GUI will automatically load in XBMC and after that everything goes down hill. 

 

Is the GUI supposed to automatically load after every reboot? Any reason I can't just uninstall the GUI from my XBMC computer? 

Share this post


Link to post
Share on other sites

Hi,

 

Using Mac Os 10.10.2 for configuring the flirc - flirc firmware 3.5. 

 

When I put the flirc in the usb - it starts acting like a keyboard and keeps hitting the 'return' key + hits arrow buttons - all the time. It started doiing this from the first time I loaded the up the flirc.

 

When I try to delete buttons, they keep appearing, same thing after 'clear configuration' is keeps appearing too- its an infinite loop - program hangs after a while. Please help me!

 

 

I cannot even configure it - when I press a button to configure it, it directly says - recorded succesfully - but I did not press a button on my remote controll.

 

btw: I pulled the all battery's from other IR remotes in this room.

Edited by beninho

Share this post


Link to post
Share on other sites

I had firmware 3.3, I believe, and everything was working very well.  I updated to 3.5 about a week ago and now I get phantom key presses very intermittently.  I can be watching cable and my fire tv will suddenly wake up and I am not even handling the remote.  Also when watching a program on the fire tv suddenly the info bar will display.  I tried enabling the noise canceler which corrects this but then the flirc is extremely slow and laggy to button presses.  I tried changing the settings on my harmony remote with relation to delay timings to no avail.

 

Is there any way I can downgrade the firmware to 3.3?

 

EDIT:

 

I actually got the firmware to downgrade to 3.3 so I will definitely monitor and ensure the issues go away.

Edited by kibosh

Share this post


Link to post
Share on other sites

Guess I was wrong about 3.3 being better . . . I continue to get phantom key presses.

Okay, I'm sorry for the delay. Can you post your configuration?

Share this post


Link to post
Share on other sites

Sure!

 

I am running Kodi 14.1 on an Amazon Fire TV.

 

I have a Harmony One remote set to Flirc XBMC. I set the interkey delay to 0ms, input delay to 500ms, and inter-device to 500ms (I have tried several settings for interkey and input delay)

Device command repeats is at 1 currently but increasing or decreasing this did not help at all when noise canceler was enabled.

 

I have noise canceler off and interkey delay at 0 using builtin profiles.

 

My current setup is nice and responsive its just odd that even though I don't touch the remote the filrc is randomly responding to something!  I just tried adding a USB extension and moved the flirc away from the Fire TV which is also in a unit with glass shelves.  I also took black electrical tape and wrapped it around the flirc only exposing the front of it.

 

It seems that the IR sensors are VERY sensitive on this unit.  I had the Flirc plugged in to the back of the Fire TV facing backwards and I can still control it no problem without a direct line of sight.  I am hoping that by wrapping it with the tape it might help block out any excessive noise it is picking up.  I will get a chance to test it out later tonight but it I haven't noticed it randomly turning on since which is a good sign.

Share this post


Link to post
Share on other sites

Sure!

 

I am running Kodi 14.1 on an Amazon Fire TV.

 

I have a Harmony One remote set to Flirc XBMC. I set the interkey delay to 0ms, input delay to 500ms, and inter-device to 500ms (I have tried several settings for interkey and input delay)

Device command repeats is at 1 currently but increasing or decreasing this did not help at all when noise canceler was enabled.

 

I have noise canceler off and interkey delay at 0 using builtin profiles.

 

My current setup is nice and responsive its just odd that even though I don't touch the remote the filrc is randomly responding to something!  I just tried adding a USB extension and moved the flirc away from the Fire TV which is also in a unit with glass shelves.  I also took black electrical tape and wrapped it around the flirc only exposing the front of it.

 

It seems that the IR sensors are VERY sensitive on this unit.  I had the Flirc plugged in to the back of the Fire TV facing backwards and I can still control it no problem without a direct line of sight.  I am hoping that by wrapping it with the tape it might help block out any excessive noise it is picking up.  I will get a chance to test it out later tonight but it I haven't noticed it randomly turning on since which is a good sign.

Are you on version 3.5 of the firmware? Are you using the built in profile, or did you record the keymappings?

Share this post


Link to post
Share on other sites

I was on 3.5 and this was occurring.  I really don't remember this happening on 3.3 so I thought I'd downgrade and was able to downgrade it myself to 3.3 . . . but that hasn't helped.  Haha unless my half-assed downgrade didn't really work . . . but it does display I am on 3.3.

 

Yes built in profile with no keys recorded.

Share this post


Link to post
Share on other sites
Here is what I get when I do a format:
 
Microsoft Windows [Version 6.3.9600]
(c) 2013 Microsoft Corporation. All rights reserved.


C:\Windows\system32>cd C:\Program Files (x86)\Flirc


C:\Program Files (x86)\Flirc>flirc_util.exe format
Warning: cannot open USB deviceFormatting Device, please wait...  Done!


C:\Program Files (x86)\Flirc>

I just went back in to the software (v1.3) and it showed 3.3 but I force upgraded anyway.  Shows 3.3.  I think sequence modifiers was on before but now its not.  I changed the interkey back to 0.

 

Sorry, I am not sure which key . . . when I use Plex the progress bar pops up then disappears after a few seconds.  With XBMC a large box appears that covers most of the top of the screen and it only shows what appears to be the current time position of the movie . . . its not the normal OSD I am not sure which key causes that to display.  Actually just playing with the remote, when I click the zoomlevel button the same popup shows.

 

EDIT:

 

ZoomNormal, ZoomLevel1, ZoomLevel2, and ZoomLevel3 on my harmony remote all cause this similar popup to show.  I noticed that they are slightly different:

 

ZoomNormal displays 00:00:00/00:49:10 [00:00:47]

ZoomLevel1 displays 00:00:01/:00:49:10 [00:00:47]

ZoomLevel2 displays 00:00:02/:00:49:10 [00:00:47]

ZoomLevel3 displays 00:00:03/:00:49:10 [00:00:47]

 

I would have to take note what gets displayed on the screen to pin-point the exact key next time it happens.  I am actually hoping I never see it again! 

Edited by kibosh

Share this post


Link to post
Share on other sites

This is fairly old topic, but I just noticed something that may be interesting to others.  I was having all sorts of trouble with phantom keys on my Macbook Pro (2010 model), both with and without noise cancellation, and I noticed that it only happens when I have the power cord plugged in to the laptop.  Even in a dark room, I get phantom keypresses if power is connected.  When I disconnect power (run on battery), I stop getting phantom keys even in a reasonably bright room.[...]

Thanks for reporting the solution that worked for you. Kudos because it seems that it worked for me as well: I was getting rapid and repeated ghost key presses until I unplugged my laptop (Fujitsu, Windows 10). That solved it! After, I had no more ghost keys and was able to program the Flirc by using the GUI.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...