Jump to content
Flirc Forums
Kahmenah

QNAP RM-IR004 Remote?

Recommended Posts

Anyone had luck with this remote?

When trying to program the buttons up, down and volume-up buttons are acting as the same, as well as OK and back , and yellow and green. 

v1 Flirc
3.2 software
3.9 firmware

 

*Also tried a Time Warner Cable remote with it, works perfect (but too big for my use case).

 

new 004
31N4b1RptbL.jpg

Edited by Kahmenah

Share this post


Link to post
Share on other sites

Really want this remote to work so got the Flirc Version 2. Still no go.

v2 Flirc
3.20.4 software
4.4.2 firmware

Same issue as before. 

Here's a Device Log showing all 17 buttons pressed in order top to bottom, left to right. 

my_flirc_log.txt

Share this post


Link to post
Share on other sites

This remote seems to use MCE protocol. I've analysed all the buttons and I couldn't find any issues with the signals. They all decoded correctly.

Flirc v2 shouldn't have any issues with MCE.

Go to Advanced settings in Flirc GUI and disable all built in profiles.

MCE protocol uses a toggle bit, which means if you press the same button two times in a row, the remote is going to send two slightly different signals. So to properly record your remote, you need to record each button twice in a row - select the same function in the GUI the second time to have both signal variants assigned to the same function.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×