Jump to content
Flirc Forums
Laurence

Wrong FW version in latest Linux x86_64 GUI?

Recommended Posts

I'm attempting to run the Flirc GUI version 3.20.2 on Linux (Ubuntu) on my first generation Flirc. The log says that I need FW of >= 4.1.0.

If I try to upgrade (File->Advanced->Force FW Upgrade) it says that my current FW version is 3.9.0 and that the latest firmware version is 3.9.00

I don't wish to risk messing up the stored key settings if the upgrade isn't going to work. Is the GUI message wrong or is the version it is going to install too old?

Share this post


Link to post
Share on other sites

Have the same problems

Running Flirc GUI version 3.20.4 on Linux 64bit (Mint 19) first generation of Flirc.
trying upgrade (File->Advanced->Force FW Upgrade) it says that my current FW version is 3.9.0 and that the latest firmware version is 3.9.00
The log says ERROR. Firmware upgrade  required. (fw >= 4.1.0.)

How to upgrade to 4.1.0 first ??

flirc_util settings gives this

myname@system:~$ flirc_util settings
flirc_util version 3.20.4 [3.20.4]
 Firmware Detected
 Version: v3.9.0
    SKU:     flirc
    Hash:    0xE31E4C1A

Settings:
  sleep detection:  Enabled
  noise canceler:   Disabled
  inter-key delay:  5
  seq. modifiers:   Disabled
[E] lib/libflirc/bootloader/bl_2.0.c fl_ver2_product_type(526): unknown or unsupported variant: 144
  variant:          Unknown
  builtin profiles: Enable

Memory Info:
  keys recorded:  0
  keys remaining: 169
  memory used:    0%
  product sku:      flirc
No Keys Found

 

Edited by SteLin
add more info

Share this post


Link to post
Share on other sites

For your reference: The working version that I installed was the 64 bit generic tar file. I did not use the apt install script.

Share this post


Link to post
Share on other sites

Hi ,

have the same problem as @SteLin.

I also tried the 64-bit generic tar file  without success. The upgrade tool will not install any firmware  >= 4.1. It offers me only the already installed version 3.9.0.

I'm desperate.

Here my settings:

flirc_util version 3.20.4 [3.20.4]
 Firmware Detected
 Version: v3.9.0
    SKU:     flirc-se
    Hash:    0xE31E4C1A

Settings:
  sleep detection:  Enabled
  noise canceler:   Disabled
  inter-key delay:  7
  seq. modifiers:   Enabled
  variant:          Unknown
  builtin profiles: Enable

Memory Info:
  keys recorded:  0
  keys remaining: 169
  memory used:    0%
  product sku:      flirc-se
No Keys Found

 

flirc.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×