Jump to content
Flirc Forums
EvilWayz

[SOLVED] New downloads for linux don't work

Recommended Posts

I have been running the 2nd gen FLIRC since it came out and never had a problem with updating.   Recently, it got held back.  So I followed the instructions on the debian 64 bit, and i get multiple unmet dependencies.  One of which doesn't exist.  I'm running 18.04, standard kernel, xubuntu desktop.

<code>

wolf@wolf-desktopbubba:~$ sudo apt install flirc
[sudo] password for wolf: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 flirc : Depends: libqt5xmlpatterns5 (>= 5.0.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
wolf@wolf-desktopbubba:~$ sudo apt install libqt5xmlpatterns5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt5xmlpatterns5 : Depends: qtbase-abi-5-9-0
E: Unable to correct problems, you have held broken packages.
wolf@wolf-desktopbubba:~$ sudo apt install qtbase-abi-5-9-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qtbase-abi-5-9-0 is a virtual package provided by:
  libqt5core5a 5.9.1+dfsg-10ubuntu1 [Not candidate version]

E: Package 'qtbase-abi-5-9-0' has no installation candidate
wolf@wolf-desktopbubba:~$ sudo apt install libqt5core5a
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqt5core5a is already the newest version (5.9.5+dfsg-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
wolf@wolf-desktopbubba:~$ 
</code>

 

 

 

Share this post


Link to post
Share on other sites

@EvilWayz please check your apt sources if they are all correct.

https://packages.ubuntu.com/bionic/libqt5xmlpatterns5

According to this, the libqt5xmlpatterns5 in Ubuntu 18.04 depends on qtbase-abi-5-9-5, not qtbase-abi-5-9-0 like in your case.

Is this a fresh install or did you upgrade from a previous Ubuntu version? From what I see, the qtbase-abi-5-9-0 was provided by Ubuntu 17.10.

Share this post


Link to post
Share on other sites

wolf@wolf-desktopbubba:~$ sudo apt install qtbase-abi-5-9-5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libqt5core5a' instead of 'qtbase-abi-5-9-5'
libqt5core5a is already the newest version (5.9.5+dfsg-0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 

Share this post


Link to post
Share on other sites

I was mistaken, i was running artful.  changed over to bionic, successfully installed. 

Edited by EvilWayz
problem resolved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×