Jump to content
Flirc Forums
pball

2nd Gen Interkey delay?

Recommended Posts

I've been using a 1st gen for years and have it setup perfectly. Just got a 2nd gen and I don't see the interkey delay option any more. Scrolling in Kodi is now too fast and I don't see a way to adjust for it, is this possible to fix?

Share this post


Link to post
Share on other sites

Here is my config.

HTPC.fcfg

 

Edit:

The second gen seems to have the same repeat rate the original did with the default interkey delay setting.

Edited by pball
attached config

Share this post


Link to post
Share on other sites

Did you load this config from the old device? Can you do me a favor. Can you format the device, record another button. When you do it, press and hold the key as you record it.

Share this post


Link to post
Share on other sites

this definitely looks different. Can you go to File->Device Log. Enable logging. Press and hold a single key for a second. Save that and post that text file?

Share this post


Link to post
Share on other sites
2 hours ago, pball said:

Here is the log.

log.txt

What kind of remote is this? Are you holding your remote too close to flirc during recording?

Share this post


Link to post
Share on other sites

Can you add the profile->

Manufacturer: Flirc

Device: Kodi

No pairing needed, it's all built in. Can you give that a shot? Not sure what profile this is, but it looks invalid.

Share this post


Link to post
Share on other sites

I'm guessing you are referring to adding a profile to my Harmony remote. I currently use a customized Panasonic TC-P65VT30 profile on my remote. I'll the Kodi profile and see what that does.

Share this post


Link to post
Share on other sites

I added the Flirc Kodi remote profile to my Harmony remote and repeat rate was the same.

I adjusted the interkey delay on my Harmony remote between 100 and 1000 and the repeat rate did not change.

The interkey delay option on the gen 1 seems to be the only way to adjust the repeat rate when scrolling in Kodi using up/down or page up/down. I did notice that changing the interkey delay on my Harmony remote had a little affect on the gen 1 repeat rate, didn't test this at multiple values like I did with the gen 2 though.

 

If there isn't a way to adjust this on the gen 2 I'll be returning it as there are zero pluses currently and one big negative with the gen 2.

Share this post


Link to post
Share on other sites

I think you need to go to troubleshooting, 'my device is sending too many signals'  something like that. This is fixable, promise. 

Share this post


Link to post
Share on other sites

go to file->device log, enable logging. Click the 'up' button only once as if you want it to move once. Post the results of that file here.

Share this post


Link to post
Share on other sites

when you added the  Flirc Kodi remote profile, did you format your device? You should have zero keys recorded. Otherwise, the existing keys will be used.  

Share this post


Link to post
Share on other sites

The log file does not match the flirc / kodi profile signals, you sure that's what you recorded in the device log?

Share this post


Link to post
Share on other sites

I went back to my custom remote and flirc config after the flirc kodi remote profile didn't change anything.

I made a new log using the flirc kodi remote profile and clearing the flirc config.

log gen2 kodi remote.txt

Share this post


Link to post
Share on other sites
12 minutes ago, pball said:

I went back to my custom remote and flirc config after the flirc kodi remote profile didn't change anything.

I made a new log using the flirc kodi remote profile and clearing the flirc config.

log gen2 kodi remote.txt

looks better, but now you need to get the interkey delay in the harmony the same as the original. It should be 75ms, where as yours is reading 24ms.

Share this post


Link to post
Share on other sites

The default is zero according to the my harmony app. Guess I'll have to play with that and the key map tomorrow.

Capture.PNG

Share this post


Link to post
Share on other sites

It can't be zero, that's impossible.

Try zero, and then go to advanced, and go to device log. Here is what we are looking for:

:e:6221
0,4915,4792,892,1579,893,1578,889,1582,893,741,918,1548,893,1579,892,1579,893,4374,864,769,888,746,866,767,919,719,888,741,892,741,893,1578,1727,1581,891,771,867,766,863
:e:24
0,4938,4792,837,1657,841,1631,841,1630,810,824,841,1630,863,1631,814,1657,836,4401,841,793,815,823,837,797,837,797,836,798,836,797,841,1657,1674,1631,837,797,841,794,815
 

The :e:24 stands for 24ms since the last pulse train. The :e:6221 stands for 6,221 seconds since the last pulse train ( button press).

You want to get that 24ms up to 75, and you're good. Keep playing with the number, checking the Flirc gui, and keep me posted.

Share this post


Link to post
Share on other sites

I changed the inter-key delay and the flirc debug still has it at e24. Inter-key at 100 or 1000 doesn't change the value in the debug window.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×