Jump to content
Flirc Forums

Flirc2 setup problem

Recommended Posts


I checked the forums, but didn't really find a topic with my problem, so I try to ask:

I have a first generation flirc and I use that without any problems for years. But I decided to get a new one, mostly becouse I have a frequent error in my mediapc/kodi that maybe becouse the old flirc reciever i got already used years back, but mostly becouse the new one is more up-to-date and let's face it, smaller, nicer and fits more to the mediapc than the old.

I got the new one, but after setting up (install software, program the keys to my remote) it didn't work at all. The windows and the Flirc cliens sees the device, when I set up a key, it says it was programmed. But when I want to actually use the remote (even just to see the keystrokes it supposed to do) nothing.

I cleared the settings, to start from scrach, set up all the keys. Now some works some not. Even the keys that does work, are unreliable. Sometimes I press the button and ok, next time its nothing for a minute (arrow keys for example, up - up - nothing for long seconds - up).

The flirc client for programming the remote keys, sometime says that a key is already stored do I want to redo? But most of the time nothing, just store it like it was empthy.

Plugging back the old flirc, works great, repsonsive, quick.

Did I miss something with the setup? Can I check somehow what keys it stored?

(the remote is a logitech harmony 350 and I did see that the harmony remotes have problems, but this is the most basic version, technically just an universal remote, and as I wrote, my old, first gen flirc works with it perfectly.)

If anyone have any idea, I'd appreciate it, thanks.

Share this post

Link to post
Share on other sites


Can you do the following?

1. In Flirc GUI, save the configuration to a file and attach it here.
2. In Flirc GUI in File menu, there's a Device Log option. It should open a log window in which you should see a checkbox named Enable IR debugging. Check it and then press some buttons on your Harmony remote (using the profile on the remote you're using with old Flirc and try to program new to). You don't need to start recording. Just press some buttons. You can try pressing each multiple times and also hold them for a moment. Then save the log to the file and attach it here.

Share this post

Link to post
Share on other sites

What profile are you using on your harmony for flirc?

Can you do the same again, but only do it with one of the bottons on the remote? Nothing is strikingly obvious at the moment.

Share this post

Link to post
Share on other sites

The harmony settings is a modified xbox. This morning I had the idea to try another device to set up in the harmony and check the flirc with that.

Saved the log, only pressed the "Play" button twice.

The "<3>ir_finished(63): too many edges" message at every button seems problematic ^^°

Thank you for the help.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now