Jump to content
Flirc Forums

Updated to Flirc 3.8 from 1.3.6, now crashing @startup


Recommended Posts

I had a working Flirc configuration based on a (FL-09028, original Gen1?) USB Flirc dongle purchased in 2014 that had been successfully programmed using the Flirc GUI v1.3.6 (don't know what firmware that would represent) and running under MacOS 10.9.5 on a Mac Mini used as an HTPC.

Had not done any Flirc reprogramming since 2015 until this week when I got my new Harmony Remote and launched Flirc to do some updates and testing.  Unfortunately agreed to the Update dialog and now Flirc GUI v3.8 crashes on launch.  Crash log shows 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib            0x00007fff86d76866 __pthread_kill + 10
1   libsystem_pthread.dylib           0x00007fff8649835c pthread_kill + 92
2   libsystem_c.dylib                 0x00007fff91a00b26 abort + 125
3   org.qt-project.QtCore             0x00000001024d4d0d qt_apple_check_os_version() + 317
4   org.qt-project.QtCore             0x00000001024183b9 QCoreApplicationPrivate::QCoreApplicationPrivate(int&, char**, unsigned int) + 153
5   org.qt-project.QtGui              0x0000000101d1853e QGuiApplicationPrivate::QGuiApplicationPrivate(int&, char**, int) + 14
6   org.qt-project.QtWidgets          0x00000001029c6568 QApplication::QApplication(int&, char**, int) + 56
7   com.yourcompany.Flirc             0x0000000101042e35 QtSingleApplication::QtSingleApplication(int&, char**, bool) + 69
8   com.yourcompany.Flirc             0x0000000101042ed4 QtSingleApplication::QtSingleApplication(int&, char**, bool) + 52
9   com.yourcompany.Flirc             0x0000000101046c67 main + 71
10  com.yourcompany.Flirc             0x0000000101042434 start + 52


Amazingly, Flirc remote functionality seems to still be intact! 

BUT, after recovering my original Flirc GUI v1.3.6, when running it says the dongle is at v3.8 but there is no other functionality to the GUI.  Flirc dongle icon shows "Disconnected" and app is very flaky, usually requiring a Force-Quit.

Really hoping I can get this running again without losing all my remote programming or bricking the dongle.  Is there an incremental upgrade path I can take with intermediate versions of Flirc GUI without going straight to 3.8?

Any help greatly appreciated!  

Edited by audio_inside
Added dates and config details
Link to post
Share on other sites
  • 2 weeks later...

Really, no clues from FLIRC Staff available to help solve this problem?

I'm inferring from the crash log that qt_apple_check_os_version() is failing.   But I can't seem to find any hard System Compatibility info at www.flirc.tv to know if my MacOS version 10.9.5 is really too far downrev.

BUMP

Link to post
Share on other sites
On 1/17/2018 at 9:07 PM, audio_inside said:

OK thanks, I know @jason's a busy guy but maybe he will eventually weigh in here.  I'm just bummed that accepting a Flirc GUI update seems to have broken my system.

send me a pm, I'll send you a new flirc.

Link to post
Share on other sites
  • 3 months later...
  • 7 months later...

Just bought a new flirc and am very frustrated that I can not install the GUI on Mac OS 10.9.   The download web site said  MacOS 10.6+

Is there any way to find an earlier version of the GUI that will run on Mac OS 10.9 (Maverick) ? 

   Jim

 

Link to post
Share on other sites
  • 1 year later...
On 1/18/2019 at 10:57 AM, Jim C said:

Just bought a new flirc and am very frustrated that I can not install the GUI on Mac OS 10.9.   The download web site said  MacOS 10.6+

Is there any way to find an earlier version of the GUI that will run on Mac OS 10.9 (Maverick) ? 

   Jim

 

I have the same problem with Mavericks 10.9.5. Any solution?

Link to post
Share on other sites
On 1/18/2019 at 12:57 AM, Jim C said:

Just bought a new flirc and am very frustrated that I can not install the GUI on Mac OS 10.9.   The download web site said  MacOS 10.6+

Is there any way to find an earlier version of the GUI that will run on Mac OS 10.9 (Maverick) ? 

   Jim

 

Exactly what kind of error or error message do you get about the inability to install the GUI on 10.9?  Does it refuse to install or does it actually CRASH after the install?

Link to post
Share on other sites
On 2/29/2020 at 11:22 PM, audio_inside said:

Exactly what kind of error or error message do you get about the inability to install the GUI on 10.9?  Does it refuse to install or does it actually CRASH after the install?

Installation of GUI goes successfully (no error message), however the program doesn't launch. You just click on it in the Application folder and nothing happens.

Link to post
Share on other sites
2 hours ago, Sergey said:

Installation of GUI goes successfully (no error message), however the program doesn't launch. You just click on it in the Application folder and nothing happens.

OK got it.  If you look in your system log then you will probably be seeing error messages like the one in my first post indicating a problem with the call to qt_apple_check_os_version(). 

Link to post
Share on other sites
7 hours ago, audio_inside said:

OK got it.  If you look in your system log then you will probably be seeing error messages like the one in my first post indicating a problem with the call to qt_apple_check_os_version(). 

Have no idea how to view system log. I wonder if you've got any help from @jason or @yawor or anybody out there from the staff and solved your problem?

Link to post
Share on other sites

I think this is because your OS is 32 bit, and it's really hard for me to make a 32 bit application. Do you have another system? You just need the app for the pairing process.

Link to post
Share on other sites
9 hours ago, jason said:

I think this is because your OS is 32 bit, and it's really hard for me to make a 32 bit application. Do you have another system? You just need the app for the pairing process.

Thanks for your reply @jason. I'm no specialist in this 32 vs 64 bit, but @audio_inside has the same 10.9.5 OS and it seems to have worked for him. Unfortunately, I cannot update my OS now because I'm using Parallels with Windows 7, and it will require updating Parallels and other stuff as well. Maybe there is a way around?

Sergeys-MacBook-Air:~ Koryakin$ uname -a
Darwin Sergeys-MacBook-Air.local 13.4.0 Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...