Jump to content
Flirc Forums
AlunS

Flirc-SE not working after power loss

Recommended Posts

I have a Streacom Flirc SE and have noticed that when power is removed completely, i.e. not just powered off, but actually physically disconnecting the power supply, it does not work on reconnecting the power unless I start up the Flirc application, which causes it to update the firmware (to the same version it was before!) after which it starts working again.

Is this normal behaviour?

Share this post


Link to post
Share on other sites

It shouldn't behave like that.

What operating system do you use? Are you familiar with using command line? There's a command line util called flirc_util which is installed together with the GUI.

Connect your Flirc, first start the GUI to be sure it's in normal mode (the software should show firmware version, not bootloader version). Then close the GUI (it's important, as GUI and cli can't be run at the same time).

On Windows, you need to open cmd.exe (or powershell) and change directory to where you've installed the Flirc software. Run "flirc_util.exe normal" (without quotes).
On Mac, you need to open a terminal and go to where the software on OS X is installed (don't have OS X so I'm not sure what's the exact path). Run "./flirc_util normal" (again, without quotes).
On Linux, the flirc_util should be already in PATH, so just open a terminal and run "flirc_util normal".

If the command is successful you should see a message like "Succesfully set device to normal operation".

After that check if this is still happening.

Share this post


Link to post
Share on other sites

It's Windows 10.

Rather annoyingly, or luckily depending on your viewpoint, it's not showing that behaviour at the moment :) I started to notice it while I was setting up my new system, so often had it disconnected from mains power for extended periods of time. I've tried disconnecting it and leaving it for a few minutes just now but it's been OK, so far.

If it does happen again, I'll try the command and see if it solves the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×