Jump to content
Flirc Forums
ianevans

A few of my keys are repeating like crazy

Recommended Posts

Just got the Flirc today and setup for my MythTV system using the Full Keyboard was pretty straightforward once I got going. However, a few of my keys (like the arrow keys on my Harmony 300) are sending multiple keypresses like crazy. So it's really hard when I'm in the guide or a menu and it jumps four spots for one button press. I saw a post about going to the advanced settings and changing a delay, but my Flirc (silver) doesn't have that setting.

 

I've attached my config.

my_flirc_config_for_buster.fcfg

Share this post


Link to post
Share on other sites

I have the same issue. Repeating Keys and no option in advanced settings to change a delay. I am on firmware 4.2.2 and Flirc v 3.1.0.

Edit: Fixed by disabling built in profiles and double recording most of the keys. Now working well with a Harmony 200.

Edited by raymondjpg
Fixed

Share this post


Link to post
Share on other sites
On 10/24/2017 at 5:31 AM, raymondjpg said:

I have the same issue. Repeating Keys and no option in advanced settings to change a delay. I am on firmware 4.2.2 and Flirc v 3.1.0.

Edit: Fixed by disabling built in profiles and double recording most of the keys. Now working well with a Harmony 200.

Same config. firmware 4.2.2 Software 3.1.0.      Everytime I press left, right or up or down, it acts like two key presses.  jumps over one selection each way.  No option in software under "advanced", as indicated as a solution in a previous version, to set up a delay.       I have another flirc and setup on another pc that is working fine.   Don't understand the above solution under "Edit".   What is double recording?      I have erased and re-programmed multiple times. Device is useless to me under current circumstances.

Share this post


Link to post
Share on other sites

I assume that you're using MCE profile on your Harmony remote. There are two solutions:

1. Like raymondjpg has done, disable built-in Microsoft WMC profile in the Advanced options in the GUI. This means the MCE profile on your remote won't work out of the box anymore. You need to use the GUI and record all your buttons to the functions you want. Because of how the MCE protocol works, every other press of the button the signal differs a little, causing Flirc to see it as a different button. So you need to record every button two times with the same function selection (for example, select volume up, press vol+ on the remote, then select volume up once again and again press the vol+ on the remote).

2. Don't use MCE profile. Either use one of Harmony flirc profiles (like flirc/wmc or flirc/kodi) which are supported out of the box (check if they are enabled in Advanced settings) or use some other profile, for example for LG, Samsung or Panasonic TV (whichever you don't have physically) and record your keys using GUI (no double recording needed). I recommend some Samsung TV profile if you don't have Samsung TV - I'm using an universal remote set to one and it works with Flirc beautifully.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×