Jump to content
Flirc Forums
jcfaber1

Flirc sending too many commands

Recommended Posts

jcfaber1    1

I purchased a second flirc and loaded my original config file to the flirc.  If you press the arrows it sends through too many (2 usually) commands.  The config file was from the first version flirc device.  The second device is V2 flirc which I restored using the original config file to the new V2 flirc device.  I searched this problem where is says to change the interkey delay.  In the flirc software, when I go to File>Advanced there is no place to change the interkey display.  What am I doing wrong?

Thanks

JOHN

 

Share this post


Link to post
Share on other sites
jason    141

I see the issue. Can you delete a key, and then re-record it, save your config?

Share this post


Link to post
Share on other sites
jason    141

I'm certain that's going to fix it. But can you also try upgrading your firmware with the attached. Check the sku in the gui File->advanced, should say at the bottom.

Then do File->Upgrade Firmware with one of the attached. And then Load a broken config, and let me know if that fixes it too. Please make sure you load the broken config, I'd like to do a mass update if this fixes it as well.

Thanks so much.

dori.release-4.1.4.bin

nemo.release-4.1.4.bin

Share this post


Link to post
Share on other sites
jcfaber1    1

Jason the fixed version did fix the problem.  I will try the firmware update this evening.  Is there one version or another you prefer?

 

Thanks for your help.

John

Share this post


Link to post
Share on other sites
jcfaber1    1

I do not think the firmware update process has worked for me.  This is what I did.

  • Downloaded Dori release
  • Went File>Upgrade Firmware>Selected Dori
  • Clicked Open
  • Loaded the original config file (firmware version number has not changed)
  • Flirc is unusable and does not respond to any remote keys

If I restart Flire it reloads firmware automatically and Flirc works as before the whole process.

image.png.bf85b0f762c19bba1f5d80235b29d659.png

This is the screen after the firmware upgrade.  Ideas?

 

John

Share this post


Link to post
Share on other sites
jason    141

I made it public. Download the latest on the main website and upgrade your firmware. Then load the first config and let me know if there are any issues. 

However, you should use my config that I posted once your done testing for me and I'll explain why after you confirm my update fixes it too. Thanks so much for the help.  

Share this post


Link to post
Share on other sites
jcfaber1    1

I downloaded the latest install exe 2.5.6.  I uninstalled Flirc.  I installed the newly downloaded version.  Opened Flirc and it still shows version 2.5.2.  I attempted to load the above firmware and original config and the Flirc was inoperable.  I inserted Flirc back into my computer and it upgraded the firmware and I went back to the fixed config,

What's next?

Share this post


Link to post
Share on other sites
jason    141

Sorry for the confusion. Throw away the bin I sent you. 

Install the the latest GUI from the website. It should prompt for a firmware upgrade. Upgrade the firmware. Then load the original config.

 

Share this post


Link to post
Share on other sites
jcfaber1    1

I did uninstall the ap/GUI this morning, downloaded and installed the GUI but it did not seem to change anything.  The screen shows 2.5.2 as well as about not 2.5.6.  When you are on the website for windows download is shows version 2.5.6 but that is not what installs.

Share this post


Link to post
Share on other sites
jason    141

Completely my mistake. I pushed another update for windows.


So to summarize, get that, upgrade your firmware, load your old config, let me know if that works.


Once it does/doesn't, let me know what happened, and then load my config that I fixed for your normal use.

Share this post


Link to post
Share on other sites
jcfaber1    1

I ran the install and it updated the firmware.  I loaded the broken config but it is still adding extra moves just as before.  For the time being, I will use the fixed config.

John

Share this post


Link to post
Share on other sites
jason    141
5 hours ago, jcfaber1 said:

I ran the install and it updated the firmware.  I loaded the broken config but it is still adding extra moves just as before.  For the time being, I will use the fixed config.

John

Alright mate, give it another go. Pushed an update, try and get the latest, upgrade your firmware,  and reload the original config. I'd like to fix this for everyone, I believe I got it.

Share this post


Link to post
Share on other sites
jcfaber1    1

And give it another go did I.  The original config file works!  Thanks!  So what is happening?  I have another Flirc that I would like to update in my house that is the original unit. (I have 3 total)  Will this work on the earlier rev?  Great Product!

Thanks.

John

Share this post


Link to post
Share on other sites
jason    141

Okay, glad it fixed it. Basically, in the new version of flirc, I record more information about the IR pattern, including the space between frames.

On the old version of the config, I never stored this information. When you load a configuration from an old device to a new device, I made up a generous number.

This translates to erratic behavior on the new flirc if the time between frames is less than what's been stored in your configuration (the made up value). I use this information to figure out if you're pressing the button a bunch. So the space between frames is 32 (as an example), but I stored 150, my firmware thinks you let go and hit the button again because the time in between frames should always be equal.

I've disabled trying to determine if you are hitting the button repeatedly if the value is the generous default I use if we never recorded the data.

So you should use the configrutaion I created for you. Basically what I did, is had you record a key, where the new firmware captured and recorded this value in between frames, and then I replaced all the default numbers with the new number. This is going to translate to a more natural feeling with your remote, where it should detect fairly well if you are pressing buttons quickly. Hope that made sense.

Share this post


Link to post
Share on other sites
apfelcast    0

Hey Jason, 

I'm also using a V2 Flirt together with a Kodi on a Raspberry Pi 3. Just a few hours ago I wanted to make same adjustments in my configuration and while my Flirt was connected to my Mac I got a notice, that a frameware update was available, so I did the framework update. Since I updated the framework I'm getting similar issues like John. I press a button once on my remote and in Kodi it looks like I'm pressing it twice or more. Never had these can't of problems with my flirt before the update. I attached my current config file. Do I have to downgrade the framework now?

Thank you.

Daniel

my_flirc_config.fcfg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×