Jump to content
Flirc Forums

My buttons are going crazy fast after firmware upgrade


EvilWayz
 Share

Recommended Posts

  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

10 hours ago, EvilWayz said:

Thanks I appreciate it. 

Okay, I've issued an update. Upgrade your firmware.

What's going on here is that your remote is overlapping with the built in streacom wmce remote profile. The easiest fix would be to disable that profile, however, I can't issue that update yet. Hopefully it'll be within a week.

The other way to fix it is to 'record over' those keys. But in testing your remote, it looks like I'm not actually recording over the built in rom buttons. This update fixes that. So record over all your buttons, and do it twice because these are those pesky buttons that have a toggle bit that flips on each successive button press. So record up, then record it again.

Do that for all your keys, problem should go away.

I can't fix the built in profile, because I don't believe all the WMCE remotes are made equally.

Let me know.

Link to comment
Share on other sites

You did the right thing clear your config. Record your buttons. That should be it. 

Explanation: If you clear your config, you'll notice your remote still works. That's because it's using the built in profile. When you record those buttons, you are effectively recording over the built in profile.

Link to comment
Share on other sites

http://cl.flirc.io/lbOd

several buttons have issues.  When you record, press and hold the button. It needs to see the second packet and when it doesn't, it saves a generic delay, which is 130. The Interkey delay is actually shorter than 130 on this remote, so it thinks you are lifting up and pressing the button again.

In other words, flirc_util settings, or filrc_util.exe settings 

find all the buttons with 130, and delete them, and re-record them. Problem will go away. I need to make a way to edit configs in the GUI, actually not very easy. I'm not good at the GUI stuff.

Link to comment
Share on other sites

Just now, EvilWayz said:

i dont understand what you mean when you say record them twice.

your remote sends out two different signals per button. Also, use the attached firmware, this is burning both our times. (disabling built in profiles).

Check which sku your device is in file->advanced.

 

dori.release-4.1.3.bin

nemo.release-4.1.3.bin

Link to comment
Share on other sites

No, but you should see that every other button press on your remote works. This is because your remote sends out alternating patterns every time you press a button. So you have to record all the buttons twice. Record up. Record up. Record left, record left. etc. Problem should go away.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...