madmanuel

FLIRC disconnected after going to sleep

208 posts in this topic

since we know v1 works, is there anyway to purchase that dongle anywhere? 

Share this post


Link to post
Share on other sites

Unfortunately no, I don't have any more. However, I'm not going to give up. I've just been swamped and I'm going to get back to this very shortly. It's not an option for me to not solve this. I will solve it.

1 person likes this

Share this post


Link to post
Share on other sites

Please keep us all updated - i have a new HTPC thats been sitting unused for 5 months waiting for this one last fix.

Bought the FLIRC for the advertised wake function and really don't want to look into returning it and using MCE receivers again.

1 person likes this

Share this post


Link to post
Share on other sites

Can you guys list your hardware, and all peripherals. I'm going to try and clone your setup.

Share this post


Link to post
Share on other sites
7 minutes ago, jason said:

Can you guys list your hardware, and all peripherals. I'm going to try and clone your setup.

Hello Jason

Sorry I have not been here lately, my health has not been too good.

The v1 is still working perfectly.

As for my hardware, it is as listed below:

ASUS H110I-Plus Motherboard (BIOS 3016)
Intel Core i7 6700
8GB Ram
Samsung EVO 256GB SSD
Windows 10 Home x64 (up to date as of today)

I hope this helps.

Thanks in advance

Kevin

Share this post


Link to post
Share on other sites
12 minutes ago, Kevin Cowans said:

Hello Jason

Sorry I have not been here lately, my health has not been too good.

The v1 is still working perfectly.

As for my hardware, it is as listed below:

ASUS H110I-Plus Motherboard (BIOS 3016)
Intel Core i7 6700
8GB Ram
Samsung EVO 256GB SSD
Windows 10 Home x64 (up to date as of today)

I hope this helps.

Thanks in advance

Kevin

What USB peripherals do you have plugged in? 

Anyone have a laptop that exhibits this?

Share this post


Link to post
Share on other sites
1 minute ago, jason said:

What USB peripherals do you have plugged in? 
 

Hello Jason

Sorry, the only USB peripherals I use are the Flirc USB and the Unifying Adapter for the Logitech K830 Wireless Keyboard.

All my Media etc. is stored on NAS.

Thanks in advance

Kevin

Share this post


Link to post
Share on other sites

Gigabyte H170N-WI-FI Motherboard

Intel Dual Core i3-6100T

Windows 10 x64

 

Other than the FLIRC I only have a 'Logitech Mini Receiver' for a Logitech LX710 keyboard and mouse. Yesterday I tried removing the Logitech Mini Receiver USB device and still had trouble waking the machine.

Happy to try any troubleshooting steps to help you.

 

Share this post


Link to post
Share on other sites

Posted (edited)

Asrock J3455-ITX with integrated CPU J3455 Apollo Lake. Windows 10 x64 ver.1703

Other than Flirc i have only mouse and keyboard both cabled USB, both Logitech.

If you need i could send you a complete log of hardware, tell me exactly what you need.

Happy to help you if needed.

Bye

Edited by Montas

Share this post


Link to post
Share on other sites

ASUS Z170i Pro Gaming ITX
Intel 6500
Windows 10 x64
GTX 980ti
USB Stuff:

Microsoft Wireless Receiver (For Keyboard/Mouse) - Which can wake my PC
Xbox Controller
The found new hardware audio plays every I wake my computer up re-installing the FLIRC.  
I've also got Wake on LAN enabled and that works too

 

Share this post


Link to post
Share on other sites
On 5/12/2017 at 4:32 AM, Lil-Diabo said:

ASUS Z170i Pro Gaming ITX
Intel 6500
Windows 10 x64
GTX 980ti
USB Stuff:

Microsoft Wireless Receiver (For Keyboard/Mouse) - Which can wake my PC
Xbox Controller
The found new hardware audio plays every I wake my computer up re-installing the FLIRC.  
I've also got Wake on LAN enabled and that works too

 

Anyone in the US willing to send me their system? I'll send it back along with some money for compensation. I worry that I'm going to waist a lot of time duplicating hardware, and have no success. Ideally, someone with a second system that experiences this on both.

Share this post


Link to post
Share on other sites

Posted (edited)

we could all pitch in and buythe less expensive motherboard, if you Jason have a compatible cpu. Or we can buy my mobo (Asrock J3455-ITX) with cpu integrated for 100$.

I'm ready to put 10$ or 20$ if needed.

Someone else?

Bye

 

OT:  Today i have build a nano-arduino ir receiver with relay, only for trigger the poweron's pins on mobo. It 's a good fallback waiting for working Flirc.

But i have faith in Jason :D

Edited by Montas

Share this post


Link to post
Share on other sites
On 5/12/2017 at 4:32 AM, Lil-Diabo said:

ASUS Z170i Pro Gaming ITX
Intel 6500
Windows 10 x64
GTX 980ti
USB Stuff:

Microsoft Wireless Receiver (For Keyboard/Mouse) - Which can wake my PC
Xbox Controller
The found new hardware audio plays every I wake my computer up re-installing the FLIRC.  
I've also got Wake on LAN enabled and that works too

 

Very kind of you. But I worry that I'm going to be waisting weeks trying to repeat it whether it's due to a BIOS difference, setup difference, Windows build difference, peripheral difference. At this point, I'd like to ask someone if they are willing to send mine, in which I'll pay for all certified shipping, and I'll also compensate you $250.00 for the help and time saving.

Share this post


Link to post
Share on other sites

ok, i understand you, but J3455-ITX is a all-in-one 100$  mobo so there's no additional peripheral other than ram and disk. I'm not using logitech wireless device, and i tried both bios available. i tried both driver from Asrock website, both latest driver from intel website. bye

Share this post


Link to post
Share on other sites
4 hours ago, Montas said:

ok, i understand you, but J3455-ITX is a all-in-one 100$  mobo so there's no additional peripheral other than ram and disk. I'm not using logitech wireless device, and i tried both bios available. i tried both driver from Asrock website, both latest driver from intel website. bye

Okay, great news, I'll order everything for it today.

1 person likes this

Share this post


Link to post
Share on other sites

Ordered all the components. Hopefully I can reproduce this on site. Expect an update about one week from today, everything arrives early next week. @Montas please send me all the details you can.

Windows 10 64 professional?

Any settings after a format?

Can you save your BIOS config and post here?

Send me a picture of all your peripherals, if possible.

What USB connectors is everything plugged into? 

Did you install any software after a fresh install? 

Any settings after fresh install?

How do you put your computer to sleep/suspend?

How long does it take for sleep to cause this? 

Is there any difference between putting the pc to sleep, waiting for hibernation, and just going to hibernation?

I'll add more if I think of anything.

1 person likes this

Share this post


Link to post
Share on other sites

Ok, i can write you all settings or i can send you a TrueImage image with my exact system. I think it will be around 30-40GB. I have enough space in Google Drive but i need few days for imaging and upload.

Bios setting are default except "Wake from USB Keyboard/Remote" ENABLED

Tell me which you prefer.

PS: there's one problem...it's all in Italian language :) I could reinstall in English if you really really really need.

Bye

Edited by Montas
1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, Montas said:

Ok, i can write you all settings or i can send you a TrueImage image with my exact system. I think it will be around 30-40GB. I have enough space in Google Drive but i need few days for imaging and upload.

Bios setting are default except "Wake from USB Keyboard/Remote" ENABLED

Tell me which you prefer.

PS: there's one problem...it's all in Italian language :) I could reinstall in English if you really really really need.

Bye

Got most of the hardware, will start assembling and installing windows tomorrow. Don't worry about uploading anything just yet. Let me see if I can reproduce this on my own first.

Share this post


Link to post
Share on other sites

I'm having the same issue.

Here is my system configuration :

  • Alienware Alpha R2 (mini PC)
  • Windows 10 Home (with all latest updates)
  • I have a dongle for a wireless Logitech K400+ keyboard in the first usb port in front (see photo)
  • The Flirc dongle is connected to the second usb port in front
  • BIOS configured with "Wake from USB" enabled (I successfully tested the wake function with keyboard connected to the PC)

2017-05-24 20.22.47.jpg

Share this post


Link to post
Share on other sites

I've got the other system up and running @Montas suggested and I've reproduced it. I'm furiously trying to find a remedy and won't stop until I do. 

2 people like this

Share this post


Link to post
Share on other sites
38 minutes ago, jason said:

I've got the other system up and running @Montas suggested and I've reproduced it. I'm furiously trying to find a remedy and won't stop until I do. 

It's a very good news that you have reproduced the problem ;)

Now i'm sure you can do that.

Good work :)

Share this post


Link to post
Share on other sites
On 5/24/2017 at 6:14 PM, Montas said:

It's a very good news that you have reproduced the problem ;)

Now i'm sure you can do that.

Good work :)

Okay guys, I think I figured it out. I pushed an update, GUI version v2.3.8 which has new firmware in it. So confident, I made it public, however, this may in fact just fix @Montas system. But I'm fairly confident. Seems to be a windows only thing, they send a set remote wake up feature request down to the device, in which case I would send a stall/nack. Windows said, 'oh yeah, fuck you' and then disconnected me. I'm now returning OK. This is not a required feature, apparently windows 10 says it is. Please don't leave me hanging if it works, please report back here and let me know. This was both brutal in finding, repeating, and solving.

2 people like this

Share this post


Link to post
Share on other sites

Awesome work @jason

After upgrading the software and the firmware, waking up the PC using Flirc works for me now :)

Thank you for fixing this rapidly!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now