Jump to content
Flirc Forums

The New Flirc doesn't work: "Button already exists"


arentep
 Share

Recommended Posts

Hello,
today I got my "New Flirc", I bought it directly from Flirc. OK, my device was pretty dirty and seems to be a used one, but it's not the problem.
If I try to set up the buttons on my remotes, it does only work for 2-4 buttons, and then I get the message "Button already exists".
What I've tried:

  • Erased all buttons;
  • Cleared the configuration;
  • Forced firmware update.

Remotes I've tried:

  • Samsung TV
  • Onkyo AV-Receiver
  • Logitech
  • Squeezebox
  • Xiaomi TV-Box
  • Apple Remote (white)

Computers I use:

  • Mac Mini
  • iMac
  • MacBook Air.

Thank you in advance.

Link to comment
Share on other sites

I ask because the plastic sometimes doesn't look pristine. Surface isn't always perfect. Even so, I don't recycle products.

However, the metal is newly released. It wouldn't even be possible to recycle material, your the first to ever receive it and see it. They just started shipping.

I have super strict quality control this go around. I'm even opening up 50% of them and inspecting them myself to ensure they are adhering to my standards. I send them emails all the time telling them what is and what isn't okay.

Your unit is not behaving correctly, let's get you a replacement. Send me an email at support@flirc.tv and I'll take care of everything.

Link to comment
Share on other sites

OK, thank you and sorry for my assumption.

Anyway, sometimes I'm getting my unit to work correctly for a couple of minutes, but then it falls back to behave the same faulty way. Not only "button already exists"; for example, sometimes even a correctly mapped button triggers a completely different function.

I will contact you, thanks for your help.

Link to comment
Share on other sites

  • 3 weeks later...

I'm having the same problem with a new flirc I just received. I have an old plastic one that works fine with the remote, but the new metal one is giving me the "Button already exists." message after it accepts the first command.

What firmware is the old one running?

Link to comment
Share on other sites

Jason-

I sent an email to support and replied there, but I'll include the information here.

The plastic flirc is running FW 3.8 and the metal flirc is running 4.0.5.

I'm using version 2.0.3 of the software, which I think may be the problem. I tried to program the plastic flirc and received the same "Button already exists." error.

Is there an older version of the software available that I can try?

The remote is a Savant universal remote.

https://www.savant.com/product/remote-host

I had no problem using this remote to program the plastic flirc before.

Thanks.

Link to comment
Share on other sites

I'm not sure you're understanding my issue.

The Savant has a Comcast cable box profile. I would like to use those IR commands with the metal flirc to control a Raspberry Pi, but when I try to program the flirc, I get the error after 2 buttons are programed.

I have a blu ray player profile on the Savant that is mapped to the plastic flirc that works, and I'm able to program the metal flirc with the blu ray profile but when I tried to program either to the Comcast remote I get the error. I tried using the remote that came with the cable box and I get the same error.

 

I don't think the flircs like the Comcast IRs.

Link to comment
Share on other sites

  • 2 months later...

I'v purchased Flirc February this year (the new metal). I have the same problem with "button already exists."

I have tried the following remotes:

  • SONY DVD RMT-D206P
  • SONY DVD RMT-D198P
  • SONY Soundbar RM-ANU191
  • Philips TV 2422 549 02314
  • Samsung TV/Box 00070A

What is the solution?

Edited by Daniell R
Link to comment
Share on other sites

Yes, from the start worked fine.

Just moved Flirc from the front to the back of PC. Seems to have made a difference somehow. Now all remote keys gets mapped and working. Will do some more user-testing and get back here.

Cleared config today to try again, to see if everything still worked. Sadly no. I get "button already exists." again. It was a short joy :(

There is no clear pattern what keys are read by Flirc as the same button.

Link to comment
Share on other sites

Cleared config today to try again, to see if everything still worked. Sadly no. I get "button already exists." again. It was a short joy :(

There is no clear pattern what keys are read by Flirc as the same button.

Aha: Does this give any idear of that's wrong?

Unplugged Flirc while PC is turned on. Plugged Flirc back in again in another USB port, and now everything works again, like yesterday evening.

Restart the PC and I get "button already exists." again, when trying to configure a remote.

EDIT: And some hours later, after getting it to work by unplug/replug, it stops working again. this is annoying.

Edited by Daniell R
Link to comment
Share on other sites

  • 2 months later...

I have a v1 Flirc (FW 3.08) and just got a v2 (FW 4.024). The remote I'm using is a DirecTV RC64RB. Both of the Flirc devices are continuously displaying the 'button already exists' message. I've tried the various inputs from the switch at the top ("DirecTV Logo"; "AV1"; "AV2"; "TV") and they actually act a bit differently. For example, while in 'TV' mode, I am unable to set each number from the keypad without seeing the 'button already exists' dialog. However, if I switch to the 'DirecTV Logo', I can successfully map each number. The one area that fails regardless of your remote mode is "Volume". Once you map one of 'mute', 'Vol+', 'Vol-', the dialog will pop for the subsequent attempt.

I've tried uninstalling/reinstalling as mentioned above with no success. I've tried different USB ports and I've ensured that I'm not pointing directly at the Flirc device (also mentioned above). I'm simply unable to map this remote. I configured the 'TV' input for major TV brands such as Sony, Samsung, Pansonic, and Pioneer. Tried 2 or 3 codes from each brand. Same issues across the board with both devices.

Please see attached for log files of this event. In each log I simply map 'mute' successfully and then attempt 'Vol -' which results in the error. Then I exit.

 

Flirc_v2.txt

Flirc_v1.txt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...