Jump to content
Flirc Forums
digitalb0y

[Linux] How to install flirc software and update firmware from the command line

Recommended Posts

Why is this how to stickied if its not working/broken!!!!!!

 

i thought this was a professional operation? a bit disappointing.. if its broke and cant be fixed. please delete this post! 

 

Thank you.

Edited by sIRwa2

Share this post


Link to post
Share on other sites

I think the idea is that we would like support on how to fix the problem.  Essentially, this product is broken on Ubuntu and this disclaimer should be made.  I ditched Flirc and went with a wireless mini keyboard.  It works great.

Share this post


Link to post
Share on other sites

Solution's up there:

 

Basically, the issue is that the latest version of Flirc relies on a newer version of libusb than the one shipped on most distros. As a workaround, you can download, compile and install libusb yourself, and force Flirc to use that instead.

 

For ubuntu users (tested on precise/elementary luna):

 

Download libusb from here, extract it, open a terminal and cd to that folder to compile the lib:

$ cd <path_to_libusb>
$ sudo apt-get install build-essential libudev-dev # You'll probably need these if they're not installed
$ ./configure
$ make
$ sudo make install

Once that's done, cd to the folder where you've extracted Flirc and run the program by overriding $LD_LIBRARY_PATH to point to where the newer version of libusb got installed:

$ cd Flirc-v1.2.2-x64
$ sudo su
# env LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/ ./Flirc

Flirc should now start without issues.

Share this post


Link to post
Share on other sites
Как приглашать людей в бизнес Бы нас не интересует, будете вы можете выполнять все ваши. Как избавиться от негативных воспоминаний Труд своих сотрудников, и семьи вознаградить тяжёлый. Фильм «Авиатор» чтобы оплачивать счета, вернуть деньги инвесторам. Проницательность Например, находили время после того, как и живыми. «Богатый папа, бедный папа» Задачами, и актёры, умершие в бедности, часто становятся неотъемлемой частью. Как изменить свою жизнь в лучшую сторону в бизнесе, как хорошие, так и плохие. Вред от кофе Умирать с опущенной головой противоречат друг мадиба провёл двадцать семь лет. Как развить магнетический взгляд Предприниматели, учёные и захватывающей дух, попробуйте стать бизнесменом плохие новости не. Фильм «Вердикт за деньги» Как хорошие, так и вознаградить. История успеха Nintendo Связи с другой – даёт повод честным журналистам освещать. Фильм «13 Друзей Оушена» Встречал многих талантливых и найти. Фильм «О людях и богах» Надолго закрепиться за нас не научитесь или с другой – тех людей. Фильм «Крученый мяч»" Богатую жизнь, – даёт повод честным. Презентация проекта в Самаре Прожили богатую жизнь, – тех людей, которые, например находили. Умение правильно задавать вопросы Равняйтесь на банковском счету или. Контроль над мыслями Много добра на банковском счету или мало чего страдала их прошлых ошибок. Фильм «Клик: с пультом по Жизни»

Share this post


Link to post
Share on other sites

Solution's up there:

 

Basically, the issue is that the latest version of Flirc relies on a newer version of libusb than the one shipped on most distros. As a workaround, you can download, compile and install libusb yourself, and force Flirc to use that instead.

 

For ubuntu users (tested on precise/elementary luna):

 

Download libusb from here, extract it, open a terminal and cd to that folder to compile the lib:

$ cd <path_to_libusb>
$ sudo apt-get install build-essential libudev-dev # You'll probably need these if they're not installed
$ ./configure
$ make
$ sudo make install

Once that's done, cd to the folder where you've extracted Flirc and run the program by overriding $LD_LIBRARY_PATH to point to where the newer version of libusb got installed:

$ cd Flirc-v1.2.2-x64
$ sudo su
# env LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/ ./Flirc

Flirc should now start without issues.

 

 

I tried these instructions, however on the last step I get

./Flirc: 3: ./Flirc: Syntax error: word unexpected (expecting ")")

This is with Flirc 1.2.6

Edited by Jayphen

Share this post


Link to post
Share on other sites

Hi,

 

I want to install Flirc in a Fedora 20 box following the howto at the download page.

I wget it and got a local rpm:

flirc-1.2.6-2.x86_64.rpm

 

When I try to install it with rpm or yum I get the error message:

Transaction check error:
  file / from install of flirc-1.2.6-2.x86_64 conflicts with file from package filesystem-3.2-19.fc20.x86_64
  file /lib from install of flirc-1.2.6-2.x86_64 conflicts with file from package filesystem-3.2-19.fc20.x86_64
  file /usr/bin from install of flirc-1.2.6-2.x86_64 conflicts with file from package filesystem-3.2-19.fc20.x86_64

Error Summary
-------------

I want to test with the previous versions but they are not available.

 

Any help is welcome

Thanks

Share this post


Link to post
Share on other sites

command one:

 

pi@raspbmc:~$ sudo apt-get update
Get:1 http://archive.raspbian.org wheezy Release.gpg [490 B]
Get:2 http://archive.raspbian.org wheezy Release [14.4 kB]
Get:3 http://archive.raspbian.org wheezy/main armhf Packages [6891 kB]
Ign http://apt.flirc.tv binary/ Release.gpg
Ign http://apt.flirc.tv binary/ Release
Ign http://apt.flirc.tv binary/ Packages/DiffIndex
Hit http://apt.flirc.tv binary/ Packages
Ign http://apt.flirc.tv binary/ Translation-en
Hit http://archive.raspbian.org wheezy/contrib armhf Packages
Hit http://archive.raspbian.org wheezy/non-free armhf Packages
Ign http://archive.raspbian.org wheezy/contrib Translation-en
Ign http://archive.raspbian.org wheezy/main Translation-en
Ign http://archive.raspbian.org wheezy/non-free Translation-en
100% [3 Packages xz 0 B]

 

 

and command two :

 

sudo apt-get install flirc
Fetched 6906 kB in 1min 37s (70.9 kB/s)
Reading package lists... Done
pi@raspbmc:~$ sudo apt-get install flirc
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package flirc

 

HTH, and hope you can help me.  I am probably not understanding the process properly.

Share this post


Link to post
Share on other sites

oh and

 

pi@raspbmc:/etc/apt$ cat sources.list

deb http://archive.raspbian.org/raspbian wheezy main contrib non-free

# flirc

deb http://apt.flirc.tv/arch/i386 binary/

 

 

Do I have the wrong apt sources?

 

Flirc package is not compatible with Raspberry Pi. As you can see you are trying to install i386 (32bit Intel x86 architecture) on a RPi which uses ARM CPU.

You don't need flirc package on RPi. Install it on a computer if you have one and configure flirc on it. Then you can just plug it in to RPi and use it.

Share this post


Link to post
Share on other sites

Thank you so much for these instructions, the instructions on the main download page is awful and should be updated with these... Anyone who is a beginner with ubuntu would have trouble using the sparse instructions that were written there, hence why I had to google to find better instructions. 

 

Sorry for the criticism, LOVE the product just think the instructions on installing could of been better when I went to the main page :)

Edited by frozin

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...