Jump to content
Flirc Forums
digitalb0y

[Linux] How to install flirc software and update firmware from the command line

Recommended Posts

There are a number of situations where you may want to configure/control flirc from the command line rather than the GUI. For example, XBMCbuntu is made to boot directly to XBMC without ever displaying a desktop environment. You may also like to be able to modify your flirc configuration via ssh without interrupting an XBMC session. In this tutorial I'll cover some basic steps for getting started with flirc from a command line.

INSTALLATION

First, we'll install the flirc software. To do this, you need to add flirc to your apt-get sources. You can do this with any text editor. Easiest is probably nano:

sudo nano /etc/apt/sources.list
Scroll all the way to the bottom of the file (Ctrl+V is page down) and add these lines:

# flirc

deb http://apt.flirc.tv/arch/i386 binary/

Save your changes (Ctrl+X exits nano, prompting you to save. Hit Y for yes, and enter to save without changing the file name). Then update apt-get to include your new source:

sudo apt-get update

Now you can install the flirc software:

sudo apt-get install flirc

Now it's possible to run all flirc commands from the command line, including programming the device, backing up your configuration, firmare installs, etc. For a list of flirc commands, you can just type 'flirc' and press enter, or 'flirc help'. For help with a specific flirc command, use 'flirc help <command>'. FIRMWARE You'll want a place for storing flirc firmware and config files. Here's how I do it: Go to your home directory if you aren't there already (in Linux, the tilde (~) represents your home directory, so if you're using XBMCbuntu and logged in as the xbmc user, 'cd ~' will take you to your home directory). If you're using another computer to do all of this via ssh, your ssh sessions will start in your home directory anyway by default. Make a folder called .flirc:
mkdir .flirc
Go to your new folder:
cd .flirc
To pull down firmware 1.0:
wget http://downloads.flirc.tv/fw/fw_1.0.bin
(Optional) Linux tip: If you use 'ls' you will see that there's now a file called fw_1.0.bin in your ~/.flirc/ folder. I use 'ls -al' (or just 'll' on most Linux builds), as that will also show hidden files and folders (like the ones with dots (.) in front of them) and the list is formatted nicer and provides much more info than ls alone. To install the firmware, make sure your flirc is connected and run:

flirc upgrade fw_1.0.bin

I don't know direct addresses for beta firmware. I'm not sure if Jason wants those to be public anyway. If he does he can add them to this thread. Either way, I'll add a post about copying files to and from an XBMCbuntu box soon.

Also, since the flirc software is now installed, you can get to the GUI if you really need to as well, by exiting XBMC and logging into xbmcbuntu from the log in window, using the same account/password as your xbmc account. Flirc will most likely be one of very few apps installed so it's not hard to find, and it looks the same on Linux as is does on Windows or Mac, but I really like using flirc from the command line honestly. It's really easy to use 'flirc delete' and 'flirc record <key>' to change buttons on the fly without interrupting your xbmc sessions.

Share this post


Link to post
Share on other sites

This isn't working for me. When I do an apt-get update, it ignores the apt.flirc.tv package sources and doesn't download them. Then when I try to install it can't find it.

My sources.list looks like this.

deb http://ftp.debian.org/debian stable main

deb http://ftp.debian.org/debian/ squeeze-updates main

deb http://security.debian.org/ squeeze/updates main

deb http://apt.flirc.tv/arch/i386 binary/

Share this post


Link to post
Share on other sites

Digitalb0y,

What kind of remote are you using? I'm trying to get my Harmony remote to work with Flirc, but they aren't playing nicely...

Share this post


Link to post
Share on other sites

This isn't working for me. When I do an apt-get update, it ignores the apt.flirc.tv package sources and doesn't download them. Then when I try to install it can't find it.

My sources.list looks like this.

deb http://ftp.debian.org/debian stable main

deb http://ftp.debian.org/debian/ squeeze-updates main

deb http://security.debian.org/ squeeze/updates main

deb http://apt.flirc.tv/arch/i386 binary/

Sorry, I put a space where it looks like there should have been a slash. Try:


http://apt.flirc.tv/arch/i386 binary/

I'm an idiot. I had it correct to begin with and momentarily psyched myself out. Not sure what was broken for optimusprime8 but the formatting in the line above should work.

It looks like Jason is redoing the page on Linux installation so I can't double check, but navigating from a browser indicates that perhaps that's the issue.

Share this post


Link to post
Share on other sites

Digitalb0y,

What kind of remote are you using? I'm trying to get my Harmony remote to work with Flirc, but they aren't playing nicely...

I use a URC RF20, which is a really misleading name as it's IR and not RF unless you buy an RF accessory, but I've been really happy with it. I chose a generic AUX profile for the remote if I recall correctly, but I'll double check when I get home to see if perhaps there's something similar in the available Harmony profiles. What symptoms are you seeing?

Share this post


Link to post
Share on other sites

Your choice of remote to use via Flirc shouldn't be affected by the OS. I use Harmony 300 with openelec and it works exactly the same as it does on my mac and my brothers PS3

Share this post


Link to post
Share on other sites

When I attempt to update after modifying /etc/apt/sources.list, I get this message:


E: Malformed line 60 in source list /etc/apt/sources.list (dist)

E: The list of sources could not be read.

Line 60 is as follows:

deb http://apt.flirc.tv/arch/i386/binary/

Share this post


Link to post
Share on other sites

My fault, I had a brain fart and second guessed myself, breaking my original instructions. The bottom of my sources.list is as follows:


# flirc

deb http://apt.flirc.tv/arch/i386 binary/

The slash before the word binary needs to be a space. I've edited the Sorry for the confusion.

Share this post


Link to post
Share on other sites

Appreciate the quick response. Flirc installed fine and I can control it (moreso once the USB receiver gets here in 2 weeks!) via command line. I'm assuming this message is something I can ignore. Correct me if I'm wrong; I'm a linux noob.

You might want to run 'apt-get -f install' to correct these:

The following packages have unmet dependencies:

 flirc : Depends: libqt4-svg (>= 4:4.5.3) but it is not going to be installed

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Share this post


Link to post
Share on other sites

Jason is better qualified than I am to answer that question, as he knows what packages flirc actually depends on to work properly, or what will break without them, but to fix the error you could try this:


sudo apt-get -f install flirc

Share this post


Link to post
Share on other sites

I'm still unable to install regardless of which syntax is used in my sources file. I am able to navigate to the folder and see the files, but my raspbmc isn't processing them. I still get:

root@raspbmc:/home/pi# sudo apt-get install flirc

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package flirc

Share this post


Link to post
Share on other sites

I got this to work by simply programming the FLIRC on a windows machine and then plugging it into the linux box. It recognized it and everything works fine. Once in a while I get repeated continuous keypresses though.

Share this post


Link to post
Share on other sites

Glad it's working. Would still like to know why apt-get isn't working on your raspbmc, but haven't had time to dig into research. I know I've seen bug reports filed with debian about similar errors to what you're seeing but don't know anything about versions yet. If programming your flirc on another machine is always an option for you, it's probably too big a deal.

Share this post


Link to post
Share on other sites

I use a URC RF20, which is a really misleading name as it's IR and not RF unless you buy an RF accessory, but I've been really happy with it. I chose a generic AUX profile for the remote if I recall correctly, but I'll double check when I get home to see if perhaps there's something similar in the available Harmony profiles. What symptoms are you seeing?

What profile are you using for the RF20? I tried the Panasonic TVs since my TV is a Samsung, but they left several buttons unused. So I went with a DVR profile that had all buttons assigned, but it's still pretty buggy.

Share this post


Link to post
Share on other sites

What profile are you using for the RF20?

I use AUX 001. It's generic so you have to add pages and define text for the custom buttons before they'll work, but every button on the thing works without issue.

Share this post


Link to post
Share on other sites

Hi 

 

I am having issues to install Flirc software in my xbmcbuntu with commandline. I followed the instructions very closely and did everything as described in this post. Still it gives me an error code.

 

 

This is what i added in /etc/apt/sources.list:
 
# flirc

 

 

When i run sudo  apt-get update this happens:

 

Err http://apt.flirc.tv binary/ Packages
  404  Not Found
Ign http://apt.flirc.tv binary/ Translation-en_US
Ign http://apt.flirc.tv binary/ Translation-en
Fetched 411 kB in 14s (28.6 kB/s)
W: Failed to fetch http://apt.flirc.tv/arch/i386/binary/Packages  404  Not Found
 
Does anyone know what could be wrong here?
 
Thanks in advance.
 
 
 
 
 
 
 
 

 

Share this post


Link to post
Share on other sites

Hi,

 

Same problem with same error message "...404  Not Found"

 

However I can share a tested workaround for Linux:

1 - Dowload the file here http://www.flirc.tv/downloads_linux/

2 - Extract the zip

3 - Open a Terminal

4 - Go into the folder (ie: cd Downloads/Flirc-v1.2.2-x64)

5 - Enter: sudo ./Flirc

6 - Enter you root password

 

You can use the utility as well

sudo ./flirc_util then choose an action then ie: sudo ./flirc_util version

 

Hope this will help

Share this post


Link to post
Share on other sites

Hi,

 

Same problem with same error message "...404  Not Found"

 

However I can share a tested workaround for Linux:

1 - Dowload the file here http://www.flirc.tv/downloads_linux/

2 - Extract the zip

3 - Open a Terminal

4 - Go into the folder (ie: cd Downloads/Flirc-v1.2.2-x64)

5 - Enter: sudo ./Flirc

6 - Enter you root password

 

You can use the utility as well

sudo ./flirc_util then choose an action then ie: sudo ./flirc_util version

 

Hope this will help

 

 

This wont work for me...

I using Xbmcbuntu..

after "sudo ./Flirc" I got this message "sudo: ./Flric: command not found"

is ther no other way??

 

tried it as root or with chmod but nothing work... as root "bash: ./Flirc: Permission denied"

 

thanks for helping

Share this post


Link to post
Share on other sites

Hi Petzi

 

As far as i know XMBCbuntu is denying to execute programms for every user by default. I have no idea why. So far i know only how to change that for each programm individually. But in this case it should do since you only need flirc to run i guess.  

 

Anyway to do it, enter the XBMCbuntu GUI. Right click on Flirc.  Go to properties or settings (sorry i'm at work and don't know the exact words but you should get the idea). And now you should see an option where you can change the rights for executing this program to everyone or only your user. After that you should be able to execute it.

 

As i said i'm at work, but if you need closer information just let me know an i'll post the exact way.

 

Cherrs!

Share this post


Link to post
Share on other sites

Hi 80Proof.

 

I dont know how but now it works. i changed it to 777 and tried it again...

but i get another problem.

 

sometimes when I start the system flirc isnt running.

then i have to go back to ubuntu and execute the file again from comannd line then it works.

is there a possibility to do this automatic with every start of the system?

Share this post


Link to post
Share on other sites

Hi,

 

Same problem with same error message "...404  Not Found"

 

However I can share a tested workaround for Linux:

1 - Dowload the file here http://www.flirc.tv/downloads_linux/

2 - Extract the zip

3 - Open a Terminal

4 - Go into the folder (ie: cd Downloads/Flirc-v1.2.2-x64)

5 - Enter: sudo ./Flirc

6 - Enter you root password

 

You can use the utility as well

sudo ./flirc_util then choose an action then ie: sudo ./flirc_util version

 

Hope this will help

 

This didn't work for me. Running Ubuntu 12.04 LTS, 64 bit version.

 

It quits with the error message:

./Flirc: symbol lookup error: ./Flirc: undefined symbol: 
libusb_get_port_number

Full response from CLI:

media@mediabox:~/Downloads/flirc$ sudo ./Flirc
[I] fl_open_devices(339): trying to open: 20A0 :: flirc.tv
[D] fl_open_devices(385):
1d6b:0002 (bus 1, device 1)
[D] fl_open_devices(385):
1d6b:0002 (bus 2, device 1)
[D] fl_open_devices(385):
1d6b:0002 (bus 3, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 4, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 5, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 6, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 7, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 8, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 9, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 10, device 1)
[D] fl_open_devices(385):
1d6b:0001 (bus 11, device 1)
[D] fl_open_devices(385):
2040:9950 (bus 3, device 2)
[D] fl_open_devices(385):
1241:f728 (bus 4, device 2)
[D] fl_open_devices(385):
20a0:0001 (bus 5, device 3)
[D] fl_open_devices(428): Vendor: flirc.tv
[D] fl_open_devices(448):  [Vendor Match]
./Flirc: symbol lookup error: ./Flirc: undefined symbol: libusb_get_port_number
media@mediabox:~/Downloads/flirc$
Edited by John_T

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...