Jump to content
Flirc Forums

Error in Config? No connection possible anymore

Recommended Posts

Flirc ist behavoring strange.

I was programming my device.

I tested it successfully a few times while I was programming it.

Then I was programming the color-buttons on my Harmony 555 (using the Samsung TV-profile).

I selected the key "Ctrl+F1" and pressed the red button on my harmony.

The Flirc-GUI said the Button already exists.

Same with "Ctrl+F2" and the green button.

Because I have had already problems with this buttons, I startet XBMC to see if the prior buttons still work.

Result: DirectionLeft and DirektionRight (ArrowKeys) didn't work anymore.

But the red and the green button now had the funktion of "left" and "right".

I saved the configuration: XBMC_20120520-1821_neue_ordnung_naja.zip

Then I plugged out/in the device just in case this would make a difference.

The GUI shows "connected".

As soons as I hit any button on the remote the device gets disconnected.

Somestimes it even connects just for a second befor the connected gets lost again. (without hitting any button).

My USB-Hub doesn't show a green LED after the connection gets lost.

I tried all my USB-Ports.

It has worked the last few days without problem. (so USB-Port and Hub are not the problem, I think)

Link to post
Share on other sites

This sounds like my problem.

I will try this, but its hard, because I barly get a connection. :(

Besides I already on FW v1.0.

EDIT: FW-(Re)Update sucessfull.

Will report further problems.

EDIT2: I cleared the Config and remapped some buttons.

Just the Direction-Buttons and Red and Green, to reproduce my previous problem.

Everything worked fine, regarding the mapping.

But now I got another issue.

When I hit DOWN on the remote in XBMC Flirc semds many more Down-commands than my Harmony sends.

And while I am writing this, Flirc seems to send a bunch of "ENTER/RETURN"-commands every now and then. (I mapped this key, too)

There really is something wrong!! :(

Link to post
Share on other sites

Hi Godzilla,

Sorry it hasn't been a smooth process for you - Jason works hard with these things so hopefully things will be smoother in future.

Glad you got your problems sorted, thanks for posting your steps - advantageous in case other user happen to have a similar issue.

When Flirc is sending too many ArrowDown or Enter/Return are you holding the button down, pressing quickly (couple of times in a second) or just pressing once?

Pleasant regards,


Link to post
Share on other sites

When Flirc is sending too many ArrowDown or Enter/Return are you holding the button down, pressing quickly (couple of times in a second) or just pressing once?

It only occures when I am pressing a button mor than one time.

But two times is enough sometimes.

My Harmony lights up wehen sending a signal, so I can assure you the signal is not repeated by the harmony as many times as flirc does send commands.

Link to post
Share on other sites

I think I found the problem.

As I mantioned before, the color-buttons ware the diffucilt ones.

I mapped now everything exepct these buttons.

Then I started to mapping the color-buttons.

But the GUI said "already existing".

So I deleted these buttons/frequencies to mep them correctly.

But I had to do the erase-routine many times till I could finally map the first color-button.

Even the GUI told me erasing was complet.

As I figured out later, It seems the GUI was deleting my previously mapped button in chronological order!! :huh:

Anyway, I had to remap my first 14 buttons!

The GUI was fine and didn't say anything about "already existing". These Buttons were definately ereased!

But the orogin of the problem is that the Samsung-profile seems to have duplicated buttons.

The colored buttons red, green, yellow and blue have the same functionality as the buttons "a", "b", "c" and "d".

I wonder why nobody noticed this before. :blink:

So, problems seems to be solved for me.

But I still think there is something wrong with the erasing-process.

Link to post
Share on other sites
I wonder why nobody noticed this before.

I'm guessing nobody has used the coloured buttons. But I appreciate you going through the trouble to figure out what was happening so I'll remember to factor that in to any issues anyone has in future.

But I still think there is something wrong with the erasing-process

Jason is working on a major UI update (hense why there hasn't been a release for a while) - hopefully it will be addressed the the next release.

Link to post
Share on other sites

FWIW, I really like using the command line to program Flirc. I did have a buggy Flirc unit at first, but even that one I could program from the CLI without issue. I got so used to doing it that way that that's how I do it even with a perfect replacement Flirc. And not only does this make it easy to tell what's mapping correctly and what's not, but in my setup it has the additional benefit of allowing me to make changes to my remote without leaving XBMC. I'm not sure about your setup, but I'm using Flirc to control an HTPC that runs XBMC. So I can ssh to the XBMC box and delete/remap a key from a laptop without ever exiting XBMC and opening the Flirc GUI.

Have you tried it that way? And do you perhaps have another system you can use to see if your problem is persistent on different computers?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...