Jump to content
Flirc Forums
urmelostsee

Flirc+Harmony+OSMC/Kodi: Volume Down-Button doesn´t work

Recommended Posts

Hello everybody,

I´m new to this forum and I hope this is the correct question in the correct forum/section.

I need some help in detail. Generally, My Harmony 650 works fine with Kodi/OSMC. My Flirc Firmware ist up to date.

As I had some not-so-good-experiences with programming another remote-Crontroll (Hauppauge), I cleared all programmings in the flirc-SW. In the harmony software I chose Flirc as manufacturer and XBMC as Device. In general, my harmony rc works fine with that, except of two buttons: "volume down" and "info" don´t do anything, volume up and mute work fine!

So I went to the myharmony-software and wanted to reprogram this vol. down button under "buttons". As I saw, that vol. down was assigned correctly, I didn´t change anything. Then I went to the flirc - sw and programmed the vol. down button. But it did not help.

Does anybody have an advice for me?

Thanks in advance! urmel

 

 

Share this post


Link to post
Share on other sites

If you are able to record buttons as the volume up/down key, on the remote, then everything is working. Now it's a matter of figuring out what keyboard keys control the volume in Kodi/OSMC. 


Try the keys listed here: http://kodi.wiki/view/Keyboard_controls

That's what should be in my GUI, but you never know, they update the shortcuts periodically.

Looks like the + and - keys.

Fire up a text editor, press those keys on the remote, and see if you see a + or - key in the text editor. That way you know the remote is working, the pairing worked, and then let's just figure out why the app isn't working.

 

 

Share this post


Link to post
Share on other sites

Hello jason,

thanks a lot for your answer! Indeed, when I press + or - key on my USB-keyboard, the result is vol up/down. Same as with F9/F10 I think.

So, I started

sudo nano test.txt

but presssing Buttons on my rc does not display any keys. The usb-keyboard does.

I think the arrow keys for example can be used to navigate in the editor, but do not display their keys.

Or did I understand something wrong?

Greetings from urmel

 

P.S.: OK I realized that you eventually meant the PC. So I repeated the experiment on the windows Computer and Wordpad.

The results are: Vol. down leads to "ß", Info leds to "i", Volume up leads to "``".

Don´t know if this helps / what this means. Play, Pause, FF/Fast Back don´t leave any traces, for example. The arrow key are used to navigate in the document as well.

 

 

 

Edited by urmelostsee

Share this post


Link to post
Share on other sites

Sorry, I'm traveling, in France right now.

I would fire up a keyboard with XBMC/OSMC, and figure out which keyboard keys cause the volume to change. Then go to my pairing applicaiton, and record those keys as the volume up/down button on your remote. 

Does that help? The keys you said that result from the remote presses may very well be because your keyboard is mapped to a different language and as such, is not sending the keys we expect. So you might have to translate your current keyboard to an english keyboard.

Share this post


Link to post
Share on other sites

any help possible? I would be glad-thank you.

Even though the Flirc itself can work with any system keyboard layout, the GUI is designed to support only US QWERTY compatible ones. The specific devices controllers (like Kodi) and built-in profiles are also not compatible with non-QWERTY layouts so it's best to not use/disable them in such situation.

I see that you use non-QWERTY keyboard on the PC (probably german QWERTZ layout). Do you also use non-QWERTY layout on OSMC? I also use OSMC but I don't remember if there's an option to change keyboard layout anywhere (because polish keyboard layout is US QWERTY compatible).

You can still use the GUI to program Flirc but it requires some extra work. You need to use the full keyboard controller in the app but don't look at the labels of the keys. Just ignore them. Look at your PC keyboard where exactly is the symbol (like +, -, or some letter or number) you want to record in Flirc (the row and how many keys from either side) and if it requires some modifiers like Alt, Ctrl etc. Then use the same modifiers and the key at the same position in the GUI (the same row etc).

For example you have - (minus) sign next to right shift button (/ and ? on QWERTY). If you want to use minus with Flirc on QWERTZ you need to record a remote button for "/" key in the GUI because it is physically on the same spot on the keyboard.

I hope I've described this enough. You can also look for my post about French AZERTY layout setup where I've also described this.

Edited by yawor

Share this post


Link to post
Share on other sites

Hello Jason & yawor,

 

thank you very much for your help. It works now! The idea to look at the change of the keyboard layout I made, was the breakthrough. Yes I have german quertz istalled (was difficult enough for me as complete a linux beginner...).

Now following yawors instructions helped me through. I am happy now with my Mediaplayer/Flirc/Harmony thing!

For other users: you might also read this thread to be informed about how to control more than one device with the harmony at once. When I choose Kodi as device, I can now control volume in the RasPi. The same buttons control volume in the receiver, when I am in a certan so called "action". The other buttons remain to be assigned to Kodi though.

 

Best regard, urmel

Share this post


Link to post
Share on other sites

Try the keys listed here: http://kodi.wiki/view/Keyboard_controls

That's what should be in my GUI, but you never know, they update the shortcuts periodically.

This statement is not fair, the Kodi developers hasn't changed the keymappings since November 2011. Source: https://github.com/xbmc/xbmc/blob/Eden/system/keymaps/keyboard.xml

Please, fix the bugs in the Native profile for Harmony remotes and it would make the life easier for many of us.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...