Jump to content
Flirc Forums
Sign in to follow this  
elddy

Harmony One - starting new activity (TV/PS3/PS4) wakes up HTPC

Recommended Posts

Hello, I have searched for an answer to my problem but no luck finding a resolution.  I setup my Flirc with my Asus Chromebox Openelec HTPC.   I setup an Acitivity on my Harmony One to "Watch Videos" and it works perfectly to wake/suspend the HTPC.  But when I switch to another activity (Watch TV or Play PS4), it will also wake up the HTPC.  Here's what I did:

  1. In the Harmony software, I added a new device under Computer>Media Center PC>Flirc>Kodi
  2. Under "Advanced setup for this device", I set it to "turn this device off when not in use", selected "one button on remote to turning it both On and Off", and set the command used to "PowerOff".
  3. I created an activity to "Watch Videos" using the Flirc device and added an additional customized button that I called "Suspend/Wake" that will send a command from the Flirc to "PowerOff"
  4. I used the Flirc software to map Ctrl + End to the customized button that I just created ("Suspend/Wake").  For some reason, it used to work with Ctrl + F12 but it suddenly stopped working.  I did a search and found Ctrl + End works but only from the main screen of Kodi.  I thought Ctrl + F12 worked in any screen in Kodi but I could be wrong.

I double-checked and all my activities do not use the FlircKodi device except "Watch Videos".  I also created a new activity to "Play PS4" thinking there was an issue with the old activity but it still wakes up the HTPC.  Does anybody know what I did wrong to wake up the HTPC even though I'm watching/playing a different activity? 

Share this post


Link to post
Share on other sites

Please do a test. Start with HTPC suspended and in some activity other than "Watch Videos". Switch to another activity, but still different than "Watch Videos". According to what you said it will wake the HTPC anyway. Wait a moment to let the HTPC fully wake.

In that state you can do two types of tests:

1. Switch between two activities (still no Watch Videos) waiting a moment between switching and check if you trigger suspend in the HTPC.
2. Switch to Watch Videos activity and check if the suspend has been triggered.

I think there may be two possibilities: either Harmony is sending a button you've recorded for suspend/wake every time when you switch activity (maybe some bug in Harmony) or you've recorded multiple different buttons for wake up.

EDIT: Have you recorded a specific button to wake the HTPC? Flirc has two wake up modes. If you don't record a wake key then every key that is recorded in Flirc can wake the PC. You can also record a specific remote button to wake the PC and then only this single button will be able to do this. But then this button can't be used for anything else.

Edited by yawor

Share this post


Link to post
Share on other sites

Thanks for you reply!  I'm at work so I can't do the tests at the moment.  I was actually trying to set the "Wake" key from the Flirc GUI to my customized button but nothing happens.  Come to think of it, I may have set the "Wake" key to the power button on the remote as well.  What's the best way to clear all the configuration from the Flirc?  I'm pretty sure I went to File>Clear Configuration before starting over again.

Edited by elddy

Share this post


Link to post
Share on other sites

I solved it.  In step #3, the additional customized button on my Harmony remote that I called "Suspend/Wake" is now just set to "0" (not "PowerOff").  In the Flirc GUI, I then set this button to Ctrl + End.  In my previous setup, I was sending the "PowerOff" command twice when switching between activities.  

  • Like 1

Share this post


Link to post
Share on other sites

The stock Flirc profile for Harmony must be misaligned as I get this too. The default is no power settings at all on Flirc/Kodi profile with "power off" being the only command. If you change the power profile in Harmony to use this by putting the system into suspend (via Kodi settings power off = suspend) it doesn't work, it will always wake the system no matter what you select on the remote.

If you don't use the built in power off command in the Harmony Flirc profile and instead do as you suggest by setting power off = number 0 then set this to Ctrl+End in Flirc software the system works as expected going to sleep when selecting another activity or powering off.

So there must be some difference between stock "power off" and "ctrl+end" the Harmony Flirc profile is sending the power off twice or something like that.

 

Update: After some research I have found a better way that makes suspend work in any area of Kodi UI, wrote a guide on how to do it all.

 

Edited by crutonbn

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...