Jump to content
Flirc Forums
RaZi3L

how to firmware downgrade

Recommended Posts

Hi
 
i was the happy proprietary of a flirc for a year. It worked perfectly out of the box with the fw from APR/MAY 2014. Until 2 days ago when I had the bad idea of a fw upgrade to the last version..... Since that moment flirck stop working randomly...
 
It is connected to an android STB (a K-R42 device) with Kodi (aka XBMC)... Initially, when is connect to the usb port of the android stb, it works well... But... few minutes after it stops working... If I unplug it and plug on my windows PC I can see the key map thorugh command line and If I open a notepad and use the remote controller I can see the typed keys....
 
Last night I tried to downgrade FW downloading GUI 1.2.4 (i think it is the one came with my flirc) from here and tried to did it as this guy explains
 
But when I try to downgrade the GUI hangs with the message "Firmware being upgraded, please wait..." and remains there indefinitely.... 
 
So please... someone can post a detailed HOW TO downgrade flirc's firmware?

Share this post


Link to post
Share on other sites

With the most recent firmware, my remotes and remote configuration no longer works with FLIRC -- so I am in serious need of a downgrade as well.

 

FW3.1 worked fine -- FW3.6 basically doesn't work at all (with my remotes).

Share this post


Link to post
Share on other sites

Hi,

 

You need to contact Jason (via private message on the forum or by email - it's available on his profile) and ask him for a downgrade. He has a lot of work and maybe missed this thread.

Share this post


Link to post
Share on other sites

I found the steps to downgrade in the Firmware > Bugs forum.  Based on a post from another user, I went back to firmware version 2.6, and my FLIRC was usable again.  A firmware downgrade was the only thing that worked for me, so hopefully it's OK to post this:

  • Download and install the GUI+Firmware version you want from http://downloads.flirc.tv/release/gui/
  • Open a command prompt, change to the FLIRC directory, and run flirc_util dfu
  • Start the FLIRC GUI

When the GUI starts, it will detect the FLIRC boot loader and download the version of the firmware bundled with the GUI.  I was never able to get the Force Upgrade button in the GUI to work, but these steps worked every time.

Share this post


Link to post
Share on other sites

Alankeny: I tried this method and it does not seem to work with V3.6 of the firmware. The GUI just always pops up the message "unsupported firmware version" and refuses to do anything further.

Share this post


Link to post
Share on other sites

This problem came up more then a month ago and one of the admins promise a downgrade guide and you guys didn't deliver on your promise until now!

 

The 3.x firmware does a lot of problem to a lot of people so until you make a normal firmware you guys need to a give us a temporary solution...

 

Please answer us ASAP i have 3 FLIRCs that i can't use because this horrible firmware.

 

Hope to hear from you soon!

 

Thanks!

Edited by adishtrt

Share this post


Link to post
Share on other sites

This device is junk. I have stopped using it because there has been no improvement in anything since 3.6 and development is non-existant.

Don't worry I will also tell my friends how terrible it is.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...