Jump to content

Wake on USB with Keyboard or FLIRC


dirty_denim86
 Share

Recommended Posts

I can't seem to get my zotac out of suspend mode by using the usb port while having a usb keyboard plugged in or using FLIRC. I have tried in the past but gave up and decide to kick the tires again but with no such luck.

I have followed the guide posted on the wiki:

Archive:HOW-TO:Enable_Wake-On-Device_for_Ubuntu (wiki)

Here is a what the lsusb command looks like:
 

Bus 001 Device 001ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001
ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001
ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002
ID 04f3:0103 Elan Microelectronics CorpActiveJet K-2024 Multimedia Keyboard
Bus 003 Device 001
ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001
ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001
ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 004
ID 20a0:0001 Clay Logic 
Bus 006 Device 002
ID 2109:0811  
Bus 006 Device 001
ID 1d6b:0002 Linux Foundation 2.0 root hub 

 

Here is the output of the cat /proc/acpi/wakeup command:
 

 
Device    S-state      Status   Sysfs node
P0P1      S4    
*disabled  pci:0000:00:1e.0
P0P4      S4    
*disabled  pci:0000:00:1c.0
P0P5      S4    
*disabled  pci:0000:00:1c.1
P0P6      S4    
*disabled  pci:0000:00:1c.2
P0P7      S4    
*disabled
P0P8      S4    
*disabled
P0P9      S4    
*disabled
USB0      S3    
*enabled   pci:0000:00:1d.0
USB1      S3    
*enabled   pci:0000:00:1d.1
USB2      S3    
*enabled   pci:0000:00:1d.2
USB3      S3    
*enabled   pci:0000:00:1d.3
EUSB      S3    
*enabled   pci:0000:00:1d.7 

 

All USB devices seem to be enabled but I am not able to resume using FLIRC or even a keyboard.

Any guidance or help would be appreciated.

Edited by dirty_denim86
Link to comment
Share on other sites

Hi,

 

As you have noticed it's not a problem with the Flirc itself as the normal keyboard is also not able to wake up your hardware. I don't know the Zotac brand so I can't tell you for sure what the problem is. You should definitely check your BIOS settings and maybe check if there is a BIOS upgrade. If this is a normal x86/x64 hardware then you could try running a Windows on it and check if it's able to configure wake up for USB devices properly.

  • Like 1
Link to comment
Share on other sites

Hi,

 

As you have noticed it's not a problem with the Flirc itself as the normal keyboard is also not able to wake up your hardware. I don't know the Zotac brand so I can't tell you for sure what the problem is. You should definitely check your BIOS settings and maybe check if there is a BIOS upgrade. If this is a normal x86/x64 hardware then you could try running a Windows on it and check if it's able to configure wake up for USB devices properly.

 

I was able to figure it out wish I saw this post sooner...

 

I noticed there was a BIOS upgrade to fix an issue with wake on usb I'm not sure if this helped or not but I did manage to get it working.

 

I had to run the following commands for all my usb ports 1 through 7.

 

echo enabled > /sys/bus/usb/devices/usb1/power/wakeup

echo enabled > /sys/bus/usb/devices/usb2/power/wakeup

 

I was then able to wake up using my keyboard I then programmed the wake button to my harmony plugged in the FLIRC device and was able to wake it up also.

 

I added the usb wake commands to the rc.local and I'm all set!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...