Jump to content
Flirc Forums
phlurker

inter-key delay being ignored?

Recommended Posts

hi,

i've got a harmony 700. i'm seeing repeated keypresses being emitted at the slightest touch of (especially) the red/green/yellow/blue buttons. i've programmed these particular keys to be alt+z, alt+x, alt+c, alt+v.

 

even after setting repeats to zero (in harmony), setting inter-key delay to 1000ms on the harmony, and setting inter-key delay to 7 on the flirc, i am still having this issue.

 

what is very odd to me is that holding a key will emit about 10 repeats a second. if i understand what inter-key delay is supposed to do, a setting of 1000ms should only emit 1 keypress a second at a maximum. but i'm still seeing about 10/s emitted.

so it seems like this setting is being ignored. does that sound right?

 

strangely, although regular keys also repeat quickly, as if they ignore inter-key delay, they don't emit multiple keypress events at the slightest touch like the ones configured with record_api do.

 

another thing i've noticed is that since recording them with flirc_util record_api, i can't delete them (they don't appear in the output of 'settings'), and i can't re-record them using the standard 'record' command (it says key already in use).

so i'm unable to test if the hair-trigger nature of the red/green/yellow/red keys is a result of using record_api, or there is something else going on (at least without formatting and losing *all* of my settings).

 

in conclusion, either i'm misunderstanding inter-key delay in thinking that it will rate-limit key repeats proportional to the specified delay, or inter-key delay is horribly broken somewhere.

and, i am unable to re-record keys as non-modifier keys that were previously recorded with record_api, nor am i able to delete them using flirc_util.

 

p.s. this is on firmware 3.0 / flirc_util 1.2.7

 

Share this post


Link to post
Share on other sites

yeah still working on it, but just open up a command prompt, and type:

 

sudo Flirc

 

It runs as super user, I just can't figure out why it wont run without elevated privileges 

Share this post


Link to post
Share on other sites

hey,

3.3 is 100% better with the record_api keys repeating, thanks.

about the inter-key delay - is my understanding correct, though? is the harmony ignoring the setting?

Share this post


Link to post
Share on other sites

yes, I need to update my command utility so you can delete them by index, they don't show up, however, you can do flirc_util delete, and then hit the button on your remote, that should do it.

Yes, sounds like harmony is ignoring it. It wouldn't be the first time. On my harmony, If I press the button twice in 20ms, it will insert a delay of 1s in between them, always. So if I hit the key 10 times, it takes ten f&*$@#'n seconds to get to my tv.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...