Jump to content
Flirc Forums
hollabaxta

Unable to learn with Xfinity Remote

Recommended Posts

Whenever I try and setup my FLIRC to learn from my Comcast Xfinity remote it always says "button already exists." I clear it, I clear it.  Nothing works.  It will not learn off this remote.  This is the remote I am trying to pair my key presses with --> http://amazon.com/dp/B00FP1B8LY/ref=pe_385040_121528360_TE_dp_1

 

 

If anyone knows what to do Id appreciate it

Share this post


Link to post
Share on other sites

Upgrade your firmware, file->advanced, force firmware upgrade.

Or,

 

disable builtin profiles in advanced settings.

Share this post


Link to post
Share on other sites

can you post a pic to your comcast infinity remote?
 

fstrife, I'm going to pick one of these up, I'll let you know how it goes. Thanks for posting a link.

Share this post


Link to post
Share on other sites

thanks Jason!

I really hope it works as the remote is one of my favorites (inexpensive, backlight turns on when picked up, has basic control for tv and receiver, large navigation pad, not too cluttered)

Share this post


Link to post
Share on other sites

Just wondering if you had any luck figuring out the issue?  I ordered the remote thinking it should work fine with Flirc...however like you can program one button.  Flirc acts like all the buttons are tied together and each isn't sending their own command.  This makes me wonder if the remote has to be pseudo paired somehow to get all the buttons to function.  Thanks!

Share this post


Link to post
Share on other sites

Yeah, I got mine and it's not working. It looks like a standard 38khz frequency, but I'm going to say the wavelength of the light is funny. It's just not working and it's going to take me time to figure out why. Sorry, guys, not something I'm going to be able to get too right away, I have a ton on my plate. 

Share this post


Link to post
Share on other sites

Yeah, I got mine and it's not working. It looks like a standard 38khz frequency, but I'm going to say the wavelength of the light is funny. It's just not working and it's going to take me time to figure out why. Sorry, guys, not something I'm going to be able to get too right away, I have a ton on my plate. 

 

Any new updates on this remote.  The XR2 that I originally posted about.  Id really like to be able to have my all in one remote control my HTPC! 

 

http://www.amazon.com/dp/B00FP1B8LY/ref=pe_385040_121528360_TE_dp_1

Share this post


Link to post
Share on other sites

Any Progress on the XR2 remote?  It appears mine programs, but it doesn't actually work...

> flirc_util settings
3.25.2
FW Version: v4.9.3
   SKU:     Flirc 2.0 [dori]
   Branch:  master
   Config:  release
   Hash:    0xCB185BDE

Settings:
  sleep detection:  always enabled
  noise canceler:   always enabled
  inter-key delay:  N/A for current firmware
  variant:          Flirc
  builtin profiles: NA
  Memory Info:      NA
  product sku:      Flirc 2.0 [dori]

Recorded Keys:
Index  hash       IK   ID  key
-----  --------   ---  --  ------------
    0  44B9308D   102  01  ,
    1  E48C9297   101  01  .
    2  B25FA939   101  01  p

...

 

Running on:

> uname -a
Linux TVBox 5.0.0-38-generic #41-Ubuntu SMP Tue Dec 3 00:27:35 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

 

I symlinked readline 6 to readline 7 to get flirc_util to work.  Probably better not to strip the binary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...