Jump to content
Flirc Forums

Alt+ or Ctrl+ or Win+ = multiple key presses


proctor614
 Share

Recommended Posts

Hello,

I've been a Flirc user for several years and was thrilled to find the update for XBMC recently.  I updated to the latest GUI/Firmware 3 days ago.  I'm finding that every time I press a button mapped to an Alt+ or Ctrl+ or Win+ combination, Windows responds as if it were several key presses (more than 3).  SO my Alt+F4 closes a program...and the computer gets shut down too, Alt+Tab FLIES through several open tasks and is like a roulette wheel on what I'll land on. 

Ctrl+ and Ctrl+Shift+ combinations do the same thing, so in Media Center, FF/REW go full throttle from the start, Record is impossible as well. 

I'm pretty sure the Win+ button combinations do the same thing but it's not as easy to test.

 

I checked ALL the other buttons in programs or notepad or both and they work fine, single press.  I tried the scale of inter-key delay from 0-6.  I'm using a Harmony 880 and never had THIS problem before. I tested using both the actual key profiles in the GUI and the Full Keyboard, same result. 

 

Win7 machine

Harmony 880

New clean config as of 09/16/14

 

my_flirc_config v3.fcfg

Edited by proctor614
Link to comment
Share on other sites

Unless I'm doing something wrong you cannot map just Alt or Ctrl or Shift to test if its the modifier that's broken.  I've mapped R, F, Tab, etc without modifiers and no abstract results.  Alt+Tab used to work fine before the update, Alt+F4 was fine.  But if I roll back firmware I'm afraid I will lose some functions that were 'fixed' in Firmware 3.0.  Namely the WMC functions, even though they are still touch and go for me.  If there was an easy way to change the keymap for WMC I'd just make arbitrary settings there as a workaround and not have to have modifiers at all.

 

XBMC uses r (or f) just fine, but WinMediaCntr uses CTRL+r or CTRL+SHFT+r (or f) and those are recorded multiple times.

Tab works fine, but Alt+Tab hits multiple times too

I'm convinced it's a problem with the modifiers.  I've even used different commands from the remote that work fine for other (single) buttom mappings and still have the same problem when I map them to a key with a modifier.

Link to comment
Share on other sites

I'm not yet on 3.0 in my setup so I'm not sure if this will help you. In RC12 Jason has added ability to enable/disable modifier key sequencing. The modifier key sequencing is a new feature in 3.0 and by disabling it you can restore modifier key behavior from 2.x firmware.

Link to comment
Share on other sites

  • 4 weeks later...

I've also been experiencing the Alt-F4 problem on a Win 7 machine using a Harmony 650.  It started last night when the directional arrow buttons started repeating like crazy, and all my settings ended up getting corrupted so I had to remap everything from scratch.  I'm using firmware 3.0, which isn't supposed to have the repeated key problem, correct?

 

At any rate, enabling/disabling the "Sequence Modifiers" option in the software didn't work for me to fix the Alt-F4 problem.  What did work for me (for the most part) was enabling the "Noise Canceler" option.  My guess is that there's been some kind of interference that's been causing these repeated key issues.  The weird part is that it only started happening last night... I've had flirc set up and working without issue for a few weeks now, and nothing's been changed where new interference would've been introduced.

 

Cheers,

Visor

Link to comment
Share on other sites

I'm getting the repeat bug again. It is definitely caused by my use of Alt+F4. No other button press with any combo of Control or Shift +key causes it. If I change the keyboard repeat rate, the Flirc repeat rate follows. It is not a remote problem as I use a URC Aero and it shows when it is sending signals. Another tell is I can cover the Flirc while it's doing this and it continues to send repeated signals. The only way I can stop it while it's in this loop is to press another key. Funny thing is the Flirc was behaving perfectly until I had an idea and decided to try troubleshooting the disconnect bug. Ah well....

 

The noise canceler didn't help at all.

 

Will keep trying to isolate it.

Edited by Pete Mazz
Link to comment
Share on other sites

  • 2 weeks later...

Temporarily changing the inter delay setting didn't work for me.  Plus, I've had to disable the Noise Canceler feature as it caused the response to be fairly sluggish.

 

So my two issues continue to be: (1) the Alt-F4 mapping, which almost always send that command twice, and (2) crazy key repeats are still occuring on average 1-2 times per week.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...