Jump to content
Flirc Forums

Support for Ubuntu 12.04 LTS?


Carl
 Share

Recommended Posts

Hi,

 

Yesterday my FLIRC dongle arrived - yeah! I tried to install FLIRC on elementary OS, which is based on Ubuntu 12.04 LTS. It's supposed to remote control the DVB-T Card. It is only for switching channels and volume control. It would be the last step on my way from Windows to Linux.

 

For the latest FLIRC software the package "libusb-1.0-0 (>= 2:1.0.12)" is needed, but you can't upgrade to a version higher than "libusb-1.0-0 (2:1.0.9~rc3-2)" under Ubuntu 12.04. LTS

 

Would be great if you could help me with that. Either by providing a stable version of FLIRC that works with the old libusb package, or with any other idea that helps.

 

I tried to find a similar topic in the forum and help from the ubuntu community before, but wasn't lucky so far.

 

Thank you in advance and greetings from the middle of Europe!

 

 

Link to comment
Share on other sites

Hmm, is that the right place to ask such questions? When was the last time someone of FLIRC was seen in this forum? well, I'll post my question again every day as long as the time runs out for returning it to amazon. So this is my question:

 

Can't install the FLIRC software from your repository in Ubuntu 12.04. LTS because it needs the package"libusb-1.0-0 (>= 2:1.0.12)", but you can't upgrade to a version higher than "libusb-1.0-0 (2:1.0.9~rc3-2)" under Ubuntu 12.04. LTS"

 

Please provide me with an older stable version of FLIRC that runs with the mentioned "libusb-1.0-0" version, or you may know another way to solve this.

 

Would be really, really great!!

Edited by Carl
Link to comment
Share on other sites

Hey Yawor,

 

apt-get tries to install flirc version 1.2.6-1ubuntu1 from the repository.

 

What I did:

1. Add 'deb http://apt.flirc.tv/arch/x64 binary/' to /etc/apt/sources.list
2. apt-get update

3. apt-get upgrade
4. apt-get install flirc

 

Let's try to translate the output of the terminal:

 

carl@X61T:/$ sudo apt-get install flirc

 flirc : depends on: libusb-1.0-0 (>= 2:1.0.12) but 2:1.0.9~rc3-2ubuntu1 is the most actual version available in 12.04

 

well it is no 1:1 translation, but you get the point. you can look it up on the ubuntu launchpads for 12.04. LTS, not possible to updgrade libusb. I tried to compile the package from source, but that didn't work out.

 

easiest way would be a stable version of flirc that runs with libusb "2:1.0.9~rc3-2ubuntu1"

 

Is there an archive on a ftp-server somewhere?

 

I use elementary os (it is under the top ten of linux distributions) which is based on ubuntu 12.04. LTS(not a small amount of those around out there as well). So there should be a solution for that.

 

Thanks in advance!

Edited by Carl
Link to comment
Share on other sites

Well, think I have to build my own IR device and work with lirc. was willing to pay more money to have a "out of the box" working dongle, but that seems not to work out with flirc.

 

Kind of disappointing of the flirc team, to be honest. Seems that they stopped support at all, not only for Ubunut 12.04. LTS.

 

Couple of days left before I have to return the dongle to amazon....

Edited by Carl
Link to comment
Share on other sites

Hey Carl, no team, it's just me here. I juggle a lot, including a full time job. And even though I have turned on notifications for new forum postings, I just don't get them all for some reason.

 

I definitely didn't stop support for Ubuntu.

 

Let's do this, can you head over to: 

 

Download the latest release candidate. Run that one. It's statically compiled with the libusb so you don't need it. Should fix it. The next public releases I'll do the same. I'm sorry I missed this thread.

Link to comment
Share on other sites

  • 4 months later...

Received my Flirc today and I'm trying to install the GUI on elementary OS (Luna) on x64. I am getting the following errors:

 

Followed the directions posted on the website and when I run apt-get install flirc it returns the following:

The following packages have unmet dependencies:
 flirc : Depends: libc6 (>= 2.17) but 2.15-0ubuntu10.9 is to be installed
E: Unable to correct problems, you have held broken packages.
 
When I try to upgrade libc6, it returns with: libc6 is already the newest version.
 
Additionally, I tried running the latest release candidate (1.3.2rc2 ), and it returns the following:
./Flirc: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
 
When I try to upgrade libstdc++6, it retuns with: libstdc++6 is already the newest version.
 
Any way around these errors and getting the Flirc to work?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...