Jump to content

CTRL-F & CTRL-B don't work in Windows Media Center


rgm

Recommended Posts

One just arrived, a rosewill, doesn't work. = (

I am assuming the Rosewill remote is the RRC-126? That is the remote I use with my HTPC. Using the Rosewill IR dongle all of the keys show up correctly in EVentGhost but they do alternate between 2 different codes (as expectded).

 

With the FLIRC, I was able to program most if not all of the codes I needed with the older firmware. In a couple of cases, the FLIRC returned 3 key presses.

 

Is there anything we can do to help out?

Link to comment
Share on other sites

I don't want to be harassed anymore. Sure, return it. I've bought 5 remotes. None of them work on 3 different machines. I'll get it working, check the latest for the update on when that is.

I keep trying and trying to get wmce remotes. It'll get fixed, can't promise a time anymore if nothing ever works for me. I'm locking this thread for now.

You can always pair the media center buttons in the GUI, those work for play/ff/rewind.

Link to comment
Share on other sites

  • 2 months later...

Unlocking this thread. Thanks to user ceeldred, I finally got a remote that's working. I'm copying everything they are doing now. I've updated the GUI, re-learn the WMCE keys, and update to the firmware included in the package, make sure you include sequence modifiers. Please, leave comments at the release candidate thread:

 

Link to comment
Share on other sites

  • 2 years later...

I am having the same problem, CTRL+F and CTRL+B not working in windows media center. It works fine from the keyboard, but not through the mapped remote through the Flirc software.

I am using the latest Flirc usb (2nd generation), and Flirc software v2.3.7. Maybe the old issue came back? That is, it sends both keys simultaneously!?
 

Edited by Ting
Link to comment
Share on other sites

7 hours ago, Ting said:

I am having the same problem, CTRL+F and CTRL+B not working in windows media center. It works fine from the keyboard, but not through the mapped remote through the Flirc software.

I am using the latest Flirc usb (2nd generation), and Flirc software v2.3.7. Maybe the old issue came back? That is, it sends both keys simultaneously!?
 

I will push this next week, I promise. Code is in there, I just need to test a bit more. I'm very sorry for the delay.

Link to comment
Share on other sites

  • 2 weeks later...
On 5/20/2017 at 1:58 AM, jason said:

I will push this next week, I promise. Code is in there, I just need to test a bit more. I'm very sorry for the delay.

Any update with the change? I just tried with version v2.3.8 and it's still having the same issue. 

Link to comment
Share on other sites

On 5/29/2017 at 2:33 AM, Ting said:

Any update with the change? I just tried with version v2.3.8 and it's still having the same issue. 

Sorry for the delay, took me a bit longer. I've got a working firmware image. I will have an advanced setting to enable/disable this. In this current version, it's enabled by default and can't be disabled. Please let me know if it's working okay. If you try to upload and get 'invalid sku' try the other image. I will update the GUI later to post more detail about the firmware, at this time, it's guess and check.

nemo.release-4.0.22.bin

dori.release-4.0.22.bin

Link to comment
Share on other sites

1 hour ago, jason said:

Sorry for the delay, took me a bit longer. I've got a working firmware image. I will have an advanced setting to enable/disable this. In this current version, it's enabled by default and can't be disabled. Please let me know if it's working okay. If you try to upload and get 'invalid sku' try the other image. I will update the GUI later to post more detail about the firmware, at this time, it's guess and check.

nemo.release-4.0.22.bin

dori.release-4.0.22.bin

 This breaks more than it fixes...

Good News:
ctrl+f (skip fwd) ctrl+b (back replay) and ctrl+d (Info/Context Menu) now work.

BAD NEWS (Below mapped commands appear to be double inputs):
ctrl+shift+f (Fast Forward) and ctrl+shift+b (Rewind) now jumps to 3x speed
WindowsLogoKey+Alt+Enter (Start Media Center/Start Page) Pops into Start Page then back to where you were (Starting WMC from desktop OK)
ctrl+g (Guide); Pops into guide then back to where you were
ctrl+p (Pause); pause 1 second then plays

How can I revert to previous firmware?  I'd much rather deal with the ctrl+f/b/d thing as it is too wonky to use remote now. Used nemo.release-4.0.22.bin (Dori gave the 'invalid sku')

Link to comment
Share on other sites

8 hours ago, jason said:

Okay, I've figured out the issue. Here is an update. I think I'm going to always sequence the modifiers by default. Don't see why not as I'm emulating a keyboard and no one can push them all at the same time.


Let me know if there are any issues.

dori.release-4.0.23.bin

nemo.release-4.0.23.bin

Still have issues, outlined below, used nemo_release-4.0.23.bin

Not working:
ctrl+f (skip fwd) ctrl+b (back replay) and ctrl+d (Info/Context Menu).

*New Not working:
Arrow Keys, Enter, Esc, Backspace
All number keys 1,2,3,4,5,6,7,8,9,0
Period(decimal)

**Working
ctrl+shift+f (Fast Forward) and ctrl+shift+b (Rewind)
WindowsLogoKey+Alt+Enter (Start Media Center/Start Page)
ctrl+g (Guide)
ctrl+p (Pause)

**all other mapped functions, not listed, work

Also note, in the Flirc GUI, key presses do not show when pressed. However, erasing the key and reprogramming works but after mapping successfully, the key presses do not show or flash green.

I reverted back to current release bin.

Link to comment
Share on other sites

Once again, thanks for the awesome feedaback. Sat down today and figured out all the issues.

  • Bug that caused all other keys to stop working without modifiers.
  • ctrl+f and ctrl+b - windows is so picky. I need to insert control, then 'f'. Then I need to release the 'f' then the control. All this is being done now.

This is probably the last one you'll test and the one that will be pushed publicly.

(Understood you are using nemo, they are identical, but for those who don't have the nemo sku, the dori is posted here too)

dori.release-4.0.24.bin

nemo.release-4.0.24.bin

Link to comment
Share on other sites

1 hour ago, jason said:

Once again, thanks for the awesome feedaback. Sat down today and figured out all the issues.

  • Bug that caused all other keys to stop working without modifiers.
  • ctrl+f and ctrl+b - windows is so picky. I need to insert control, then 'f'. Then I need to release the 'f' then the control. All this is being done now.

This is probably the last one you'll test and the one that will be pushed publicly.

(Understood you are using nemo, they are identical, but for those who don't have the nemo sku, the dori is posted here too)

dori.release-4.0.24.bin

nemo.release-4.0.24.bin

Success! All mapped keys work as they should. Thank you for fixing this! No more keyboard within arms reach needed :-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...