Jump to content
Flirc Forums

Flirc -- Will not upgrade firmware


Recommended Posts

I have 2 Flirc's, both with the same issue. They have been running along fine for a while now, no firmware upgrades in quite some time. I want to take advantage of some of the improvements in XBMC control and also add the harmony profile so I went to upgrade today, but both cycle through saying "Could not upgrade firmware, contact support" when I try to do so in the 1.2.6 gui. It seems to crash frequently while trying this as well. This is the same on a laptop running Win7 x86 and on a desktop running Win7 x64, both with fresh program installs.
I would try to do the upgrade via command line but can't since I don't have access to the bin file that is bundled in the gui. I did check the current version there and it says "Bootloader 10.5". Let me know what I can do or what other information I can send you to get this figured out.
Link to comment
Share on other sites

  • 2 weeks later...
Just for kicks I fired up linux as well with the exact same result. This is both using the default libusb shipped on ubuntu 14.04 as well as compiling the latest version 1.0.19 and forcing it as described It automatically tries to update the firmware, quickly fails while asking me to contact support, and loops doing this until I quit the program.
I would appreciate some support as these units are glorified paperweights until this gets fixed.
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I had the same issue.. but it works now. This is what I did.

I used a Windows 7 Pro 32-bit computer.

Plugged in the FLIRC

Used the diag program shown above to update the drivers.

Then unplugged and then re-plugged the FLIRC.

I then started the FLIRC program

Went to Advanced and forced an upgrade of the FLIRC firmware.  This appeared to hang at one point...

When the upgrade hangs, I then used the diag program to install the driver for the FLIRC again.

The upgrade finally finished.

I exited the FLIRC program, and removed the FLIRC from the USB port.

Restarted the FLIRC program

Reinserted the FLIRC into the USB drive.

When the green Happy-Flirc appeared in the lower right-hand corner, I was able to program it easily.



Edited by JKUSHEN
Link to comment
Share on other sites

  • 5 weeks later...

I've been gone for a while, but still thanks for the advice JKUSHEN. Unfortunately this doesn't work for me, either with the 1.2.6 stable release or 1.2.7 / 3.0.4 beta from the forums.


My issue really seems more like an incompatibility between the old firmware and the new GUI. This isn't the first time such an issue has popped up: 


Jason apparently knew what was going on and fixed it. Would be nice to hear from him here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...