Jump to content
Flirc Forums

Samsung Galaxy S4 used as remote control not recognized


Recommended Posts



I have a Samsung Galaxy S4 which also has an ir booster.


When I install an app, which uses the ir booster to control my Samsung LCD TV, this works. When I then use my Galaxy to pair some keys with flirc, flirc does not recognize any key. When I take the original Samung remote control flirc recognizes the keys.


Is there a difference between the original remote control and the Galaxy?


Thank you for your answer.



Link to comment
Share on other sites

It would appear that there is a difference.

I don't have a IR phone to try it on though i'm still a little surprised this is the case.

Harmony remotes don't have a problem with flirc (and this is essentially what the S4 is acting as)


Dumb question but when you are pairing the two is it a case that the phone and flirc are both expecting an IR input to store and assign to a key. So in actual fact neither of them are emitting anything

Link to comment
Share on other sites

I just tried again to pair my Samsung Galaxy with running remote control app with flirc.


First I selected "clear configuration".

Then I selected the full keyboard, klicked the key "1! (got the Message press the button to be paiered with "1). And then I pressed the "1" on the remote control app4. But nothing happens.

Then I pressed the "1" on the smartphone some more times and then I got a window from flirc with the text "Button already exists." and the possibility with cancel or redo. When I click redo, the window comes again (without any more action from me). When I klick cancel I can try another key. But this has the same effect, except, that the error windows comes up directly after the first press on the smartphone. 


One more interesting thing.


I also have a tablet with an ir booster. Also there I have a remote control app. And when I pair some keys with flirc, this works as expected.


Now, the question comes up: is the ir booster of the smartphone working at all. Yes it works, because I can control my Samsung LCD  with the smartphone.


If you have any questions, let me know, that I can help you.




(I run Gui 1.2.6 and Firmware v2.6)

Link to comment
Share on other sites

  • 7 months later...
  • 5 weeks later...

I have tested S4 by using another application called AnyMote. 

I was able to program Flirc with a random remote chosen inside it. And control Kodi with it.

I have to admit that not all the keys from all the remotes that are inside AnyMote are suitable to be recorded by Flirc. Some keys have more problems than others. 

The official application in S4 I haven't tested it.

Link to comment
Share on other sites

I have solved the problem by using the

USB Infrared Toy v2

which costs about 20,- US$.


Link to this page and select the USB Infrared Toy:




another address, where you can buy it is





The software I used can be found here:


The IR Scrutinizer software is a bit more than most IR Toy users will want, but it does solve the immediate issue of capturing multi-part signals using the IR Toy. You can fetch it here:


Discussion/help here:



With this IR Toy, I was able, to determine all ir signals of all my remote controls.


I hope, this info ist usefull.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...