Jump to content
Flirc Forums

Button presses not being recorded

Jake G

Recommended Posts


                I have been using Flirc for a month and a half now and a few weeks ago re-installed windows on a new hd. Immediately after the re-install I installed the flirc hardware and the drivers. It worked fine until yesterday when one button push resulted in the button acting as if it was held down. My immediate response was to try to force update the flirc firmware (no change) so I cleared everything out, reinstalled the gui and drivers and now when I try to program the remote it doesn't do anything. 


- I'm running windows 7 x64

- I'm using a universal wr7 remote (changed the batteries)

- I tried different profiles on the remote and tried my tv's remote

- I've tried disabling built in profiles but it always gets checked when I go back in

- I've tried deleting the driver and reinstalling it using Zadig 

- I'm using a wireless keyboard/ mouse and unplugged it from the usb port

- I've tried different usb ports 

- I've tried running the gui as admin


I've done a bunch of googling and reading through the forum, and pretty much tried just about everything I can think of and hope you guys can help me out here. Thanks!


Edit* I got it to pick up key presses but it's back to treating is as if the button is held down. 

Edited by Jake G
Link to comment
Share on other sites

Under which condition do you use the flirc device?

Is this behaviour reproducable under any Program, or is it always the same program?

Are you using XBMC 13(Gotham)?

I was using it for XBMC, WMC, hyperspin, and steam. I'm using Gotham, but it does it through-out windows. When I have the gui window up I can see the key blinking green.

Link to comment
Share on other sites

  • 1 month later...

Wish I could tell you more, but I have the same remote, and the same problem.  In my case, I am trying to use the Flirc with an Ouya and XBMC.  It sometimes responds, sometimes it doesn't.  As for the Universal remote, I have it using the Microsoft/XBOX quick setup under the AUX button.  As for the Flirc, I am using the XBMC pre-built commands.


However, I just wanted to test my Flirc, and so re-did all the XBMC commands using an old remote I had laying around (Hauppage media center remote that came with an EyeTV ATSC/NTSC tuner from many moons ago).  It works without a hitch.  I conclude that the problem is not in the Flirc, but in how the Universal WR7 sends its codes out.  I don't think there's any way to change this.  But it could be that the speed of the transmission from the WR7 is just a tad slower than the speed of a normal remote, and so the Flirc is getting tripped up.  Only a hunch, and probably wrong, but an idea.


TL:DR, its probably the WR7, and not the Flirc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...