Jump to content
Flirc Forums
flaviosa

Ghost clicks - Raspberry Pi + Openelec

Recommended Posts

Hi guys,

 

I really don't what do do here. My Flirc keep sending the back button from time to time (like I pressed the back) what happens is when I am watching a movie xbmc returns to the previous screen all the time.

 

If I leave only my receiver and my pi on I can hear the key presses from time to time.

 

What can I do?

 

I setup my harmony with the Flirc Media Profile so there is no chance that interference is the problem.

 

 Thanks

Share this post


Link to post
Share on other sites

Which XBMC-Version are you using?

The Gotham betas and the rc1 have an issue with remotes (ir and RC), which causes randomly nonstop key repeats.

This isn't an issue due to the flirc device.

I'm searching for a solution at the moment, but didn't found anything yet.

  • Like 1

Share this post


Link to post
Share on other sites

No, this is an issue to xbmc itself. Raspbmc has a workaround in its settings, but this do not work for me.

You can use the latest stable version (OpenELEC 3.2.4) or Raspbmc with XBMC 12.3.

There you will have no problems.

 

I have two pi's running with raspbmc (Gotham RC1) running.

The one using the flirc device is running without any issues, even no constantly repeats.

The second one is running the same config, but using a keysonic rc remote. Here this nasty issue persists.

 

I'm trying to play with the advancedsettings.xml at the moment. I will post the results ;)

Share this post


Link to post
Share on other sites

I just installed the 3.2.4 and the ghost touches are still there. It keeps hitting the back button by itself all the time.

 

So annoying.

 

Need to find another alternative. or my flirc device is defective.

Share this post


Link to post
Share on other sites

You definitely have keys recorded:

 

File->Clear Configuration to remove all the keys from the device.

 

You have multiple buttons recorded, some of them are probably noise, so that's the problem.

 

⚡  flirc_util settings

flirc_util version v1.2.2 [v1.2.2-38-g44ce387+]

  Firmware: v2.3

 

Settings:

  sleep detection:  Disabled

  noise canceler:   Disabled

  inter-key delay:  6

  state:            0

  builtin profiles: Enable

 

Memory Info:

  keys recorded:  42

  keys remaining: 127

  memory used:   33%

 

Recorded Keys:

Index  hash        key

-----  ---------   ---

    0  564BDB2D    c

    1  98A09CA6    i

    2  569C9742    return

    3  5A4ED8FB    escape

    4  D643DDA5    up

    5  98A06C59    left

    6  98317117    down

    7  5A8E00CB    right

    8  18DF869B    '

    9  98B9FA15    .

   10  568F2D26    r

   11  5A129B6C    f

   12  9817D1BC    x

   13  187DC197    space

   14  654A801E    up

   15  493207AB    up

   16  90CD4E5    down

   17  89E89C89    left

   18  C70F5D7C    backspace

   19  6506D070    up

   20  6D590996    up

   21  6D9D5C48    down

   22  6DE1ADEB    left

   23  6D9DBB52    right

   24  6D9D39EC    return

   25  6D9DBBF2    backspace

   26  CFBAA99    i

   27  D3DDD74    p

   28  4E257E98    space

   29  8D2489D6    x

   30  6D25E44A    i

   31  6DE1B1C7    p

   32  6D9D3DC8    space

   33  6D9D5E15    x

   34  6DE19485    i

   35  6D598B0B    f

   36  6D9DFF0A    r

   37  6D9DDAD0    backspace

   38  6DE18A8F    i

   39  4D614687    [

   40  8C6051C5    ]

   41  6D9D3FF5    c

Share this post


Link to post
Share on other sites

But it's still fact, that you will probably face random key repeats using xbmc gotham beta thru rc1. The recently released final isn't available for our pi yet.

 

To check, if your flirc device is faulty, just try another remote around you, learn the basic keys to flirc and see, if the flirc devices behavior is changed (or still repeating the back key).

 

Is it only the back key, which is causing the issue?

Share this post


Link to post
Share on other sites

It was only the back button. Its been 3 days since I cleaned all the buttons and its not happening any more.

 

All sorted and I am using the latest openelec beta.

Share this post


Link to post
Share on other sites

Same problem over here with Beta 4.0.2 Gotham.

For now Iam gonna switch to 3.2.4

 

I thought it was powersupply problem. Glad to know it is bug in XBMC.

 

Thanks for your input nobuddy0816

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...