Jump to content
Flirc Forums
juramusger

[solved(kind of)] sensitivity in dimlit room/Plasma TV interference

Recommended Posts

Hi board,

I received my flirc last week (very fast delivery!) and am quite happy. One thing I noted is that it is very sensitive (perfect I'd say) at daytime but at night I have to point my remote very specifically in the right direction. [update: this description doesn't capture the problem really, see my for a better one.] (The av receiver picks the signals up much more easily and I thought it would be the other way around) Can I try something to optimise this?
Noise cancelling is off and inter key delay at 3.

Thank you and thank you Jason for this device!

 

Update: It seems to be my TV interfering, even more so in the dark. I am in contact with Jason on how to resolve this.

 

Update 2: The cause of my problem was interference from my Plasma TV. Jason was very helpful in troubleshooting this with me, in the end he even sent me makeshift shades to remedy the problem. Even though this didn't resolve the issue perfectly I can live with pointing the remote fairly directly at the Flirc - hey, this is how most remotes work anyway.

For anyone having similar problems: try to cover your flirc with shades, for example made from exposed film. This might reduce IR-interference.

Also, use a 'dark' skin for XBMC or whatever software you are using if your TV is a plasma - the problem is naturally worse the brighter the screen is.

 

Update 3: While my plasma still interferes and line of sight is still required with it on, it has become very much better with newer firmware for the Flirc.

Continued support and improvements for great hardware, what is not to like?

Edited by juramusger

Share this post


Link to post
Share on other sites

Have you tried turning on the noise cancelling?

Also the dimly lit room scenario - have you tried turning electronic items in the room that may not be on during the day that maybe affected flirc at night?

Share this post


Link to post
Share on other sites

Thanks for the answer Chris!

 

I have tried noise cancelling and it doesn't seem to change anything. No other devices either, but checking that was a good suggestion.

I have a new theory though: At night we often roll up in blankets at this time of the year and I guess they will lessen the reflection of our surroundings.

 

The funny thing is that sometimes the AVR blinks as it recognises a remote press (it does so even when it doesn't react, I use the directional keys for flirc which don't do anything for the AVR while not in a menu) and the Mac doesn't react, even when I'm right in front of the flirc. It seems to me that this happens when I don't press the button all the way down or at a slight angle. I tried to learn this "slight press" but it doesn't seem to give a different signal, flirc GUI says "button already learned"

 

It's not too bad really. I just thought that I maybe missed some command for the CLI to increase sensitivity and was a bit surprised that the AVR picks the signal up more easily.

 

Really love the Flirc and just wished I had found it before I spent weeks unsuccessfully trying to find a universal remote I liked.

Share this post


Link to post
Share on other sites

Hmm.. there is a CLI command for increasing sensitivity (unless it's been taken out recently). Have you tired re-programming flirc to see if it makes any difference?

Share this post


Link to post
Share on other sites

Hmm. Which one would that be?

 

Thank you for your help!

 

I get the following commands:

 

  delete         Delete next remote button flirc sees from saved database

  delete_index   Delete button at index displayed in `flirc_util settings`

  dfu            Kick in or out of Device Firmware Upgrade mode

  dump           Dumps contents of eeprom to console

  format         Remove all saved buttons from flirc

  help           Show this help. Also try `help <command>`

  interkey_delay Test run command

  keys           Shows the recorded remote keys and their pairings

  loadconfig     Load configuration file from disk to flirc

  noise_canceler Noise canceler to prevent phantom presses

  normal         Put flirc in normal user mode

  peek           Peek EEPROM address

  profiles       enable or disable built in profiles

  reboot         Displays all the devices current settings

  record         Record infrared buttons and link them to HID keys

  record_api     Advanced button recording

  saveconfig     Save configuration file to disk

  settings       Displays all the devices current settings

  sleep_detect   Turns on sleep/suspend detection

  space          Displays information about the space used and remaining

  status         Last Flirc Status

  upgrade        Uploads new firmware image to flirc hardware

  version        Print the application version and device version if connected

  wait           Waits for the device to be plugged in (used for scripting)

Share this post


Link to post
Share on other sites

Oops, my bad. It was removed in RC 1 recently: 

 

Try a reprogram of flirc (if you haven't done it already) to see if it's having an odd moment we can't pinpoint

Share this post


Link to post
Share on other sites

So I did format the flirc and learned all buttons again, the results are the same.

 

For good measure I also tried to learn with noise reduction enabled, this wasn't possible for some buttons, even being very close to the flirc. So I reformatted again and learned again without nr.

 

If you have any more ideas, I'm open to try them.

 

Thank you!

Share this post


Link to post
Share on other sites

Hmm, start a support conversation (http://flirc.tv/contact/) with Jason and he'll troubleshoot it with you personally. Make sure to include this thread link so he can see what you've already tried.

 

Flirc shouldn't be behaving like this

Share this post


Link to post
Share on other sites

Update: 

 

(I did open a support conversation and haven't heard back yet, which is totally ok, I know that Jason is the sole developer and I think he does an awesome job responding personally very often in the forums)

 

I tried around a lot the past couple of days and it seems that how well lit the room has only little influence over my problem. (I haven't found a way to change the thread title, maybe I'm just blind)

There seems to be a general sensitivity "problem" with my flirc. It just doesn't respond well to short key presses at certain times, while at others it does perfectly. Very untechnically speaking it seems to need a pause and wants to be left alone sometimes, then it comes back a few seconds afterwards and starts responding again. It does not then issue the commands received in the meantime, as you sometimes experience with various programs when the processor is taxed too much. Setting the interkey delay to 0 seems to help a little bit but doesn't get rid of the issue completely and results in double presses, so I changed it to 1.

However, these "pauses" do more often occur if I send commands from a position not directly in the line of sight, and can sometimes be broken out of by pointing at the flirc directly, which led to my previous description of the problem.

 

Thank you for your attention! Any help is very welcome. Still I repeat that while this is inconvenient it is not a deal breaker for me.

Share this post


Link to post
Share on other sites

very very late update on this: newer firmware makes this much much better.

Thank you, Jason, for the awesome product that flirc is and your continued support.

I continue to recommend it as the best way to add IR capabilities to computers.

 

Edit: just to add: switching on noise cancelling makes my FLirc hardly pick up any signals from my remote, whether learning or after learning without it on just controlling. It might just be that the remote that I am using sends codes that are hard to pick up with noise cancelling? anyway, I am a happy customer, I just wanted to add this if you are interested and I would test stuff if you'd like me to.

Edited by juramusger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×