Jump to content
Flirc Forums

Search the Community

Showing results for tags 'WakeUp'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Flirc forums
    • Getting Started with Flirc
    • Remote Buddy 2
    • General Questions
    • How To
    • Show Off
    • Remote Controls
    • Ideas and Suggestions
    • Bugs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests

Found 2 results

  1. Simple question first: Is there any way to prevent all button presses except one from waking up the Shield TV? My Environment: I have an HTPC that is running an old version of XBMC, and I control it with a Harmony 650 using a MCE IR dongle. For 4k and HDR stuff, I have been using my Shield TV with its terrible remote. Today was the day that I was going to finally hook up my Flirc to the Shield TV and have one remote to rule them all. I actually got everything working great, except for the wake up issue. When I am blasting Kodi commands to the HTPC, they wake up the Shield TV. It's not all IR commands (like volume up and down) that wake up the Shield TV, but there are a lot of them that apparently overlap. What would be amazing is if I could assign a single key (that I don't otherwise use for the HTPC) to wake up the Shield TV, and only that key (all others to be ignored). Is there any way to do that? The other thought I had was to just map different IR codes to the Full Keyboard controller (which I did), but it seems that the XBMC commands on the HTPC still wake up the Shield TV. Is there any way to make it to where the Flirc only recognizes certain IR codes and no others? My attempt at that was to program my Harmony with some old X10 IR codes, and I then mapped those to the Full Keyboard. It all worked, but again, the other ones still worked too. Does that make sense? I'm super close to having this work perfect for me. Just the one last thing. Any ideas?
  2. These are instructions that worked for my ubuntu 12.04-based XBMC HTPC. None of the other howtos I could find actually worked for me. Recent ubuntus (e.g. 12.04 or later) use udev and automatically query the "wakeup" capability of USB devices, and allow setting the "wakeup" property of the device only if it supports it. The "stable" FLIRC firmware does not expose the "wakeup" capability to the kernel. Only later "fw_wakeup" betas do (starting in v2 I think). Anyhow - here is the procedure that did the trick for me - YMMV but at least this will give you some hopefully useful pointers :) For wake-up to work with newer ubuntu’s with udev, the “Wake Up Firmware v6” is required. This method works in recent ubuntus (e.g. 12.04 or later) Connect FLIRC to the HTPC - then do: ..... Bus 005 Device 003: ID 20a0:0001 Clay Logic Note: Bus 5, Device 2. Note also: Vendor ID: 20a0; Device ID: 0001 lsusb -t …. /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ohci_hcd/5p, 12M |__ Port 4: Dev 3, If 0, Class=HID, Driver=usbhid, 1.5M |__ Port 4: Dev 3, If 1, Class=vend., Driver=, 1.5M Note: Bus 05, Port 4 Now if flashed with a “recent wake up” firmware, FLIRC will advertise via USB that it can wake up the machine, and this can be verified by querying the “power” capabilities of “Bus 05, Port 4”: ls /sys/bus/usb/devices/5-4/power active_duration control runtime_enabled wakeup_active wakeup_max_time_ms async level runtime_status wakeup_active_count wakeup_total_time_ms autosuspend persist runtime_suspended_time wakeup_count autosuspend_delay_ms runtime_active_kids runtime_usage wakeup_hit_count connected_duration runtime_active_time wakeup wakeup_last_time_ms If “wakeup” shows up in the listing, all is good. With the original “non-wakeup” firmware, no wakeup capability was showing up. Note: the old (pre udev) way of activating wakeup (sh -c 'echo "USB4" > /proc/acpi/wakeup') no longer works in ubuntu 12.04+ Now we can manually test if wakeup works by doing (note the use of the "bus" and the "port" addresses): echo enabled > /sys/bus/usb/devices/5-4/power/wakeup Suspend / resume should now work. This could be added to rc.local - the problem with this approach is that if the FLIRC is moved to a different USB port, wakeup won’t work. The best approach is to create a new udev rule: cd /etc/udev/rules.d/ vi 90-flircwakeup.rules SUBSYSTEM=="usb", ATTRS{idVendor}=="20a0", ATTRS{idProduct}=="0001" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'" This will allow wake for the FLIRC no matter where it is connected. Note that for wake up to work, the “wake up” key has to be recorded using the “flirc” utility.
×
×
  • Create New...