Jump to content

prbeauchemin

Members
  • Posts

    2
  • Joined

  • Last visited

Everything posted by prbeauchemin

  1. OK, Got it working finally with your example. I was able to successfully transmit the message from computer #1 to computer #2. But I had issues when transmitting from computer#2 to computer #1. I was getting the error: "[E] util/flirc_util/src/cmds/ir_transmit.c sendir(96): Error: invalid length, must be even" I re-installed flirc and rebooted computer #2 and then things worked as expected. Follow-on question ... Since I can capture the remote buttons in FLIRC, then is it possible to transmit these same values either by providing the 'keystroke' that was defined, or perhaps getting access to the pattern that was stored in FLIRC?
  2. I have been using Flirc for my application for almost 2 yrs now, and I have have no issues with both Flirc devices to receiving commands from my remote controls. I wanted to try sending an IR command and the device doesn't seem to send anything. I have 2 Flirc devices with the latest release (Firmware Version: v4.9.3, SKU: Flirc 2.0 [dori]). (BTW, I am working on Windows 10) When I execute the command line: flirc_util.exe sendir --pattern="0,1,2,3,4,5" --repeat=3 (the content of the pattern is irrelevant) Output is : "Transmitting IR Pattern...Done!" The GUI log states: *** Device Connected *** Firmware Version: v4.9.3 SKU: Flirc 2.0 [dori] Git Hash: 0xcb185bde <3>ir_transmit_set(140): error, ik delay: 0 < 13000. Defaulting to 40000 The outcome is the same whether I have "enable IR Debugging" set or not. Since I have 2 Flirc devices, I connected them to 2 different computers and positions the flirc devices within inches of one another. I started the Flirc GUI on the second machine, and the log view never displays anything when the above command line is executed from the first computer (regardless of whether "enable IR Debugging" is set or not.) When I point any remote control directly at either Flirc devices, then there is an output generated in the log (when "enable IR Debugging" is set). Therefore, I seems that my devices are clearly able to receive input, but don't appear to be transmitting. Is there suppose to be any visual indicator when a Flirc is transmitting? Is there any other permission or setting I need to set? Perhaps, the version of the devices that I have don't support IR send? Any advice? Thank you
×
×
  • Create New...