Jump to content
Flirc Forums

ariflirc

Members
  • Content Count

    6
  • Joined

  • Last visited

  • Days Won

    2

ariflirc last won the day on April 3

ariflirc had the most liked content!

Community Reputation

2 Neutral

About ariflirc

  • Rank
    Curious Flirc-er
  1. self reply: issue solved - Upgraded the Flirc SE firmware to the latest available for gen1: v39 - Re-recorded the Wake key (Harmony is programmed to send "FLIRC > AspectRatio" as the power-on command. made sure that "sleep_detect" is activated. It just worked; turning off other Activities like Netflix will no longer cause the HTPC/Flirc to wake up. Before, I had v37 and it seems sleep_detect wasn't working.
  2. @jason was this firmware feature ever released? Can you advise in which release? With a FLIRC SE (so: generation 1, firmware 3.7), I've been having this issue for a long time. I posted yesterday on this in the forums [1]. I couldn't find any clear release note anywhere to see what features/fixes are included in what release. If not released, can you please release it and cover FLIRC SE / generation 1? many of us out there with first gen FLIRCs Also if the feature is already there, would you mind advising how to activate it? Thanks [1]
  3. I"m using FLIRC SE, with a linux-based Kodi HTPC build (mini ITX fanless etc). This build has been working great for a year now. The FLIRC SE is only connected to USB - without the connection to the Power Supply, as I only need it to wake the HTPC from "suspend to RAM" (S3) state, I don't need it to wake the HTPC from S5. The remote is a Harmony Hub with the simple RF remote (they call it Harmony Companion these days). I use it to control the HTPC (Kodi), the Smart TV and my Receiver. Overall, it works great but there is one annoyance thought that I could not work around after I added more than one "Activity" to the Harmony Remote. Activity 1 is "HTPC" (FLIRC) In Harmony > Setup > Devices > FLIRC > power settings, I use "Use two different buttons", and using FLIRC's programming utility, I mapped "AspectRatio" to the "wake" event. For power off, I used the programming utility to map to the "F12" key. I did this because I use some custom script that gets triggered by F12 and check if it's OK to suspend, and later trigger suspend. The FLIRC device in Harmony is setup to "Turn off when not in use" This setup works fine: HTPC suspends and wakes perfectly. Activity 2 is "Netflix", launching my smartTV's Netflix client. This activity does NOT include FLIRC in it; it only controls the TV and the Receiver. It also works fine, turning on and off just works. Here's the problem: when I turn OFF Activity 2 "Netflix", the HTPC turns ON for some reason. Eventually, Kodi's idle timer will suspend it again. But this is annoying. It seems like FLIRC is catching infrared events that the Harmony hub is sending to the TV or the Receiver, and then sending some keypress to the HTPC, and the HTPC is waking up on any keyboard keypress. Wondering if anyone ran into this issue and was able to solve it. Ideally, FLIRC should NOT be sending ANY keypress to the HTPC while the HTPC is in suspend mode except for the "Wake" keypress when it is received by IR. Is there a way to enforce this?
  4. I bought a flirc streacom edition. My HPTC runs Fedora, I can't run windows nor ubuntu. I downloaded the "static universal pacakge", it's called 2.0.4 however the GUI version tells it's 1.4.4. I tried to upgrade firmware, but it tells me that FLIRC SE is already on the latest version, 3.6. This doesn't seem correct since I see references everywhere to firmware 3.8. It seems there is a problem with the "universal package" having an older GUI and older firmware. To the dev - can you please make it simpler and allow people to upgrade to firmware 3.8 or whatever the latest stable firmware is via command line - flirc_util seems to work, I only need the proper bin file. Can you please post a link to the latest firmware. Thanks
  5. Using a Denon receiver remote - it gets difficult to use FLIRC at times due to the constant key repetition Hoping this will be addressed reasonably soon :)
  6. These are instructions that worked for my ubuntu 12.04-based XBMC HTPC. None of the other howtos I could find actually worked for me. Recent ubuntus (e.g. 12.04 or later) use udev and automatically query the "wakeup" capability of USB devices, and allow setting the "wakeup" property of the device only if it supports it. The "stable" FLIRC firmware does not expose the "wakeup" capability to the kernel. Only later "fw_wakeup" betas do (starting in v2 I think). Anyhow - here is the procedure that did the trick for me - YMMV but at least this will give you some hopefully useful pointers :) For wake-up to work with newer ubuntu’s with udev, the “Wake Up Firmware v6” is required. This method works in recent ubuntus (e.g. 12.04 or later) Connect FLIRC to the HTPC - then do: ..... Bus 005 Device 003: ID 20a0:0001 Clay Logic Note: Bus 5, Device 2. Note also: Vendor ID: 20a0; Device ID: 0001 lsusb -t …. /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ohci_hcd/5p, 12M |__ Port 4: Dev 3, If 0, Class=HID, Driver=usbhid, 1.5M |__ Port 4: Dev 3, If 1, Class=vend., Driver=, 1.5M Note: Bus 05, Port 4 Now if flashed with a “recent wake up” firmware, FLIRC will advertise via USB that it can wake up the machine, and this can be verified by querying the “power” capabilities of “Bus 05, Port 4”: ls /sys/bus/usb/devices/5-4/power active_duration control runtime_enabled wakeup_active wakeup_max_time_ms async level runtime_status wakeup_active_count wakeup_total_time_ms autosuspend persist runtime_suspended_time wakeup_count autosuspend_delay_ms runtime_active_kids runtime_usage wakeup_hit_count connected_duration runtime_active_time wakeup wakeup_last_time_ms If “wakeup” shows up in the listing, all is good. With the original “non-wakeup” firmware, no wakeup capability was showing up. Note: the old (pre udev) way of activating wakeup (sh -c 'echo "USB4" > /proc/acpi/wakeup') no longer works in ubuntu 12.04+ Now we can manually test if wakeup works by doing (note the use of the "bus" and the "port" addresses): echo enabled > /sys/bus/usb/devices/5-4/power/wakeup Suspend / resume should now work. This could be added to rc.local - the problem with this approach is that if the FLIRC is moved to a different USB port, wakeup won’t work. The best approach is to create a new udev rule: cd /etc/udev/rules.d/ vi 90-flircwakeup.rules SUBSYSTEM=="usb", ATTRS{idVendor}=="20a0", ATTRS{idProduct}=="0001" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'" This will allow wake for the FLIRC no matter where it is connected. Note that for wake up to work, the “wake up” key has to be recorded using the “flirc” utility.
×