Jump to content
Flirc Forums


  • Posts

  • Joined

  • Last visited

htpcguy's Achievements


Newbie (1/14)



  1. Hey guys, Just wanted to add my two cents. I have the same problem that's been listed here multiple times at this point. Sometimes my FLIRC unit seems to work fine with PHT, other times it's virtually unusable because of many, many errant key presses (and subsequent uncontrollable scrolling). This has been an on and off issue, and until I saw this forum I had always assumed it was related to firmware or PHT updates. Based on aggregating the recommendations here, I used a bit of black electrical tape, once around the USB receiver (leaving the front exposed). This seemed to mitigate the problem to some degree. I also reprogrammed it with my Harmony from scratch and then ran 'flirc_util settings'. Everything looks normal there. I have each key programmed in exactly twice to account for the issue with Harmony remotes. I have all CFLs installed in my apartment, so the IR output should be minimal. The Asus NUC I use is running very cool, and the FLIRC is cool to the touch. I don't think either are putting off enough IR to fool the receiver. Just to double check the lighting I turned everything off, and the problem persists. One thought I had is that my plasma TV puts off quite a bit of heat, but I don't have an extra monitor to test this while the TV's off. Can anyone replicate the issue with a cooler running LCD TV? It's usable now, but it still does get caught scrolling occasionally, though not for as long as it did before. A permanent and complete solution would be excellent.
  2. Jason: No problem, I'm just glad I didn't spend too much time digging deep into the device wake options. Would it be possible to switch between the two modes in the advanced options? Right now with my Harmony I could see wanting to use any button since the buttons take a pretty hard click to activate, but I could see it being a problem with more sensitive remotes, so a single wake key would be better there. dirty_denim86: I binded a key on my Harmony remote to the Flirc Wake command (which is on the full keyboard configuration, top right area). From what Jason says it seems the current Flirc firmware only listens for this particular command rather than any button press like a typical mouse or keyboard. The command I was using in my original post to make the Flirc port a wake up device was actually fine in my case, The problem was that I assumed any Flirc key would wake up my computer, rather than the just the "wake" button. Have you tried to enable/disable with a keyboard/mouse that you know normally works as a wake up device in the same USB port you're using for Flirc? I did this as a quick test just to make sure that Ubuntu was actually responding to my USB wake up changes. Just in case it helps though, here's a list of everything I did: 1) add "tee" command to my sudoers file so that it does not require a password when run with elevated privileges (this is not good practice, but for a media computer that I don't want to pull a keyboard out for it seems the only option) 2) add "echo enabled | sudo tee /sys/bus/usb/devices/1-2/power/wakeup" so that the USB port is automatically enabled at startup 3) Bind Flirc key "ctrl+alt+z" to a button on my Harmony (i.e. Guide) 4) Bind Flirc key "Wake" to a button on my Harmony (i.e. Menu) 5) Make Ubuntu keyboard shortcut "ctrl+alt+z->sudo pm-suspend &"
  3. Thanks Jason, that did the trick! Can't believe I went through all that trouble and didn't realize there was a built in wake button.
  4. Hi guys. I have a question. I recently purchased an ASUS Chromebox M004U, which I set up with a fresh install of Ubuntu 14.04. Using a Harmony Smart remote, I can pair buttons using the FLIRC application perfectly, and I can use the Ubuntu keyboard settings to bind a FLIRC key press to suspending the computer (via "sudo pm-suspend &"). My problem is that regardless of what computer keys I bind a FLIRC button with, the FLIRC receiver will not bring my computer out of suspend. I have tried using the same USB port with a wireless keyboard and mouse, and in both cases I can manually enable USB wake up by using "echo enabled | sudo tee /sys/bus/usb/devices/1-2/power/wakeup" However, this same strategy does not work at all for the FLIRC receiver when it is plugged into the same port. Enabling the entire hub (replacing "1-2" with "usb1") causes the computer to come immediately out of sleep. I believe this is from the bluetooth or other built in modules being attached to the USB bus. I don't know how important this is to my particular issue, but I forced an upgrade to the most recent firmware (2.6), and tried enabling sleep awareness in the advanced options. Neither change had any effect. Does anyone have any ideas that might help me sort this out? Any help would be greatly appreciated!
  • Create New...