Jump to content
Flirc Forums

Phydeaux

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Phydeaux

  • Rank
    Junior Flirc-er

Recent Profile Visitors

1,234 profile views
  1. This has been a very helpful thread - many thanks to CRUTONBN for taking the time to document this. This would all work very well if it didn't make the assumption that the MyHarmony default settings for the FLIRC/Kodi device included the keyboard "ctrl-F12" for the PowerOff command. Several other threads which I read also indicated that this was now part of the MyHarmony profile for the device. But it was not the case for me... and I have a few grayer hairs because I didn't validate this first. I followed the directions to a T, but selecting PowerOff always resulted in the Kodi shutdown menu. I'll spare the reader the variety of things I tried and get to the punchline: MyHarmony put the keyboard "s" for the PowerOff command. I finally validated this by watching the keyboard in the FLIRC software while I pressed the PowerOff button, yep, "s" lit up. The quick resolution was to the change the line: <f12 mod="ctrl">XBMC.Suspend()</f12>To: <s>XBMC.Suspend()</s>Bliss at last! Now if I could just figure out why my Harmony activity of turning on the TV, Amp and Kodi takes SO long before it exits and I can use the buttons... But that's for another forum. Edit: OK, using the s key wasn't ideal since whenever I needed to enter text in Kodi (search function etc) if I hit s it would suspend. lol I remapped the PowerOff command on the remote in FLIRC to ctrl-F12, so I'm in line with the "standard" Cheers! Robert
  2. An update for all on the status. Firstly, I must confess that I was thinking about the InterKey Delay exactly backwards. I mistakenly thought that the lower the number, the less delay I would see between the multiple on-screen results of holding down a remote button. Even when Jason suggested I set the delay to 6, which was counter to my assumption about how it functioned, I egotistically thought "he must have meant keep it at the other end of the scale, like 1 or 2". I humbly accept git of the month nomination. Setting InterKey Delay to 6 has taken care of the remaining issue I had with the one FLIRC I upgraded to FW 3.5. I DO find the process of programming a little dodgy, although my last go 'round when pointing the remote at the ceiling seemed better than previous attempts when simply pointing the remote "away", like previously with FW 2.2. Honestly, for me, and with these two remotes - I prefer FW 2.2 and will be keeping my other two FLIRC devices on that FW version. I can't exactly put my finger on it, but something doesn't quite feel polished about FW 3.5, although like I say I have no issues with that FLIRC and remote now at all. It's working fine. The one FLIRC I had an issue with seems to have lost it's mind. Sometimes the software will see it and sometimes not. Most times you can upgrade the FW to 3.5 but it takes like a millisecond to do so. Learning buttons is just like my original post x10. And the result is almost entirely non-functional. I think this one has had the biscuit. Jason, I'll send you a PM shortly. Thanks so much for your help. RLW
  3. How can I tell what bootloader they are? I the first one I purchased is probably 2 years old or more and the other 3 are maybe 18 months. I'm using Linux. I removed the FLIRC, closed the software, then reinserted it and restarted the software again. It now sees the FLIRC again. I forced a FW update and it completed properly. I cleared the memory and recorded keys onto it. It was not as easy as the other one I just did. Lots of glitches with it not remembering buttons again like in my original post. And same symptoms when used with XBMC. Oh well, at least one is fixed except for the delay thing. If I leave the delay at 6, that is the worst setting for scrolling through big lists. I could grow a beard while I wait to get from the A's to the Z's. It's still slow at a setting of 2 but at least I can control the rest of XBMC without false clicking everything in sight. Thanks, RLW
  4. Further to my last post, I rebooted my computer and then the FLIRC software could see the FLIRC again. But it was acting weird so I tried to force a FW upgrade. I failed partway through with this message "Could not upgrade firmware. Contact Support". Thanks, Robert
  5. OK, we're making progress. In the past I have always just recorded keys when pointing the remote away from the FLIRC and it worked great, having learned not to point directly at it when close. But I tried your method of pointing the remote at the ceiling and all buttons recorded without incident. They all tested fine too, pressing the buttons and watching the onscreen keyboard. I should note that I did clear the configuration before I did this. I plugged it into my XBMC computer and the buttons are now working correctly and consistently in XBMC from 5 meters away, so very happy about that. There is one remaining difference from FW 2.2. Previously, when in a large list in XBMC (for instance I have several thousand items in one list), if I held down the down arrow XBMC would cycle through the list very quickly. It no longer does that. It depends on where I set the Inter-Key Delay. I can make it go fast if I set delay low but then when elsewhere in XBMC I can hardly control things, when each button press repeats so quickly. If I set the delay higher, then the list scrolling is even slower. This was not a problem previously, although I don't recall where the delay was actually set. I just know I had no issues with controlling buttons clicking too fast but the list scrolling was blazing fast. Oh-oh. Seems like I just bricked one of my other FLIRCs. The program froze and I had to kill it. Now it won't see the FLIRC. Is there a fix for this? Sorry, I should look around in the forums I guess. But is there? :) Thanks, Robert
  6. OK, that's fair. And I'm willing to do my part to get this working and hopefully help you also. As I say, in the past I have pointed the remote away from the FLIRC when learning buttons. But I can try pointing to the ceiling if you think it will make a difference. Thanks, Robert
  7. Yes, I've noted that in the past it can cause problems. I pointed the remotes away from the FLIRC just like in the past. Thanks, Robert
  8. I don't have any problems with double presses at all. I'm lucky if I get a single press. If you've read my OP, you'll note that I had nightmares trying to get them programmed at all after the FW upgrade. But now that they finally are, they only work when less than a meter away. And even then they sometimes register a button press and sometimes not. And the time between button press and result on XBMC is very large. Everything is very slow. I think I gave a good description in my OP... Is there some reason I can't go back to FW 2.2? Thanks, Robert
  9. They are basic Panasonic remotes that came with my TVs. I have two marked N2QAYB 000704 and two marked N2QAYB 000820 (the longer one). Both work 100% with the FLIRCs at firmware 2.2 and neither works acceptably with the FLIRCs that have been updated to firmware 3.5.
  10. Love my FLIRC devices, I have four and they've been working very well with XBMC (OpenELEC) using the Panasonic remotes that came with my TVs. However.... I decided I wanted to assign an additional button to a keypress. I downloaded the newest software (1.3.4) since I had reinstalled my computer since the last time I did anything with FLIRC. Plugged it in and it offered to update my FW to 3.5 and I allowed it to happen. I also thought, for some reason, why not erase the settings and re-learn them all. And I did this to two of my four FLIRCs. They are basically useless now after spending hours with them. Learning the buttons is just flakey. Sometimes the button is saved and other times it's not, but the software always says successfully recorded. Testing immediately afterwards sometimes shows it did record, sometimes not. Relearning the button without first erasing it sometimes tells you the button has already been done, sometimes it just records it again (even though it previously said it had successfully recorded it. When it does say the button has already been learned, you can cancel and try to record again and the next time it will happily say successfully recorded. Testing the remote by pushing buttons and watching the onscreen keyboard takes ages - having to relearn buttons over and over. Finally, it looked good. Every button worked against every correct onscreen key.... And only about 75% of the functions work when plugged back into the XBMC box. And only if you stand within two feet. Previously it was 100% at 15 feet away and very responsive. Now it's slow as can be. Also, when in a big list in XBMC, previously if you held down the "down arrow" on the remote, XBMC would cycle through the list fast as expected. Now it's perhaps 1/4 of the speed. And, yes, I played around with the Inter-Key Delay settings to no avail. The next two FLIRCs I made a button change to, I did not let the software upgrade my FW and they continue to be a joy to use. There MUST be a way to go back to the 2.2 FW, otherwise these two FLIRCs will be of zero value. PLEASE ADVISE!!! Regards, Robert
×
×
  • Create New...