Jump to content

faginbagin

Members
  • Posts

    6
  • Joined

  • Last visited

Posts posted by faginbagin

  1. OK so the above command works and my flirc generates Ctrl+P when I press the appropriate key on the remote, but here's what's weird. The key doesn't show up when I type "flirc_util settings", but an index (in this case, 3) is skipped. Here's the output:

    flirc_util version v1.2.6 [v1.2.6]
      Firmware: v2.6
    
    Settings:
      sleep detection:  Disabled
      noise canceler:   Disabled
      inter-key delay:  4
      state:            0
      builtin profiles: Enable
    
    Memory Info:
      keys recorded:  10
      keys remaining: 159
      memory used:    6%
    
    Recorded Keys:
    Index  hash        key
    -----  ---------   ---
        0  1F4078A3    >
        1  5F190E7C    <
        2  DF5224B7    *
        4  148C61EE    next_track
        5  DF895EFB    next_track
        6  D467F8DB    prev_track
        7  1FCEF6C8    prev_track
        8  404078A3    play/pause
        9  DF3B78A3    stop
  2. I would like to program one of my remote's keys to generate Ctrl+P, which I believe should be possible using flirc_util's record_api command with arg1 = 1 for Left Control and arg2 = p. But when I type this command, I get the message:

     

    hit a key on the remote to be paired with 1 0
     

     

    (Note the 0, not P)

    If I then press a remote key and then test the result using xev, I find that the key only generates Ctrl_L up/down events. No P.

     

    This is with version 1.0.6 on Mythbuntu 13.10 saucy. I have been able to record over 60 keys using "flirc_util record char", including pageup/down, return, space, etc. I just can't get Ctrl+P.

     

    I also noticed that "flirc_util settings" doesn't show the ctrl key in the list of recorded keys, although the count of recorded keys increases after I record that key.

  3. apt-get install ia32-libs

    Found this link:

    http://askubuntu.com/questions/107230/what-happened-to-the-ia32-libs-package

     

    I was able to get a list of the needed shared libraries using the "readelf" command and started installing some. But it's time consuming to find the package name that provides the desired shared library, and I wonder if the ABIs will be compatible. So I'll manage with flirc_util for now.

  4. Just want to say "Me too". I'm running Mythbuntu 13.10 saucy x86_64, upgraded from Mythbuntu precise 12.04. I am logged in as root when I try to execute ./Flirc, but I get the following error:

    -su: ./Flirc: No such file or directory

     

    But the file is there and if I type:

    # file ./Flirc

    I get:

    ./Flirc: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.0.0, not stripped

     

    But if I try to check what shared libraries it needs with the command:

    # ldd ./Flirc

    I get:

            not a dynamic executable

     

    I don't have any 32 bit executables to compare to, but running "file" on the typical 64 bit executable says:

    <filename>: : ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=<long hash code>, stripped

     

    Perhaps executables built against GNU/Linux 2.0.0 cannot run on distros using GNU/Linux 2.6.24?

     

    FWIW, I just downloaded the zip file 1.0.6 last night, which was dated Dec 18 01:57.

     

    flirc_util works, for the most part, more details in a separate thread.

     

    HTH

×
×
  • Create New...