Jump to content
Flirc Forums

Leaderboard


Popular Content

Showing content with the highest reputation since 05/19/2019 in all areas

  1. 1 point
    Hi guys, If you can't connect to your Flirc (Generation 1) on Windows 10, this guide might help you.If you are uninterested about the possible cause of this problem go ahead and scroll down to "Try this"From the beginning I thought the issue was caused by the software/firmware, plain and simple. As it turns out, that's not it... I've tried versions from v.3.10.0 to latest 3.22.4.and all reported the same thing.After troubleshooting all day long I believe this particular issue has risen all of the sudden, in my case. After two major Windows updates.Everytime A feature update is installed all USB Devices are re-installed. But not always in the same place. If you ever used the Device Manager and checked "Show hidden devices" You've probably seen some grayed out devices. These are devices that aren't currently connected OR they've been installed in another location. So if Flirc was installed on location A prior to an feature update. Flirc might now be installed on location B. Where on location B some other device was previously installed and are now casing mayhem...that is my theory anyways after doing what I did which you now will read about. Try this1. Open the Device Manager by Right-Clicking the Windows Logo on the Taskbar.2. In Device Manager, select View and "Show Hidden Devices"3. Remove Flirc from the USB port and uninstall the software, then remove the Flirc folder.4. In Device Manager, uninstall (Delete, Enter) any grayed out devices in all the areas shown on the picture.5. Restart.6. Install latest Flirc.7. Connect the Flirc.8. If it doesn't work. Try using different driver for your USB controller* Then repeat 1-7.9. Let me know how it goes. * especially If you have an ASMedia controller. Uninstall and use Microsoft's version.
  2. 1 point
    Hi all, I bought a Flirc SE. It works great for controlling Kodi, etc. However, I'm trying to use the "SE" functionality of it and actually have it power off/on the computer. When I go into the Flirc software though, to bind power toggle to a button on my harmony remote, the software says that the Flirc is disconnected, in the title bar. Which is weird, given that it definitely works. I've tried fully uninstalling/reinstalling the software and drivers, but no luck. Anything I can try?
  3. 1 point
  4. 1 point
    Ok @jason, I think I figured out what is causing this... I decided to take advantage of my 5 FLIRCs and several computers to swap around different FLIRCs on different computers. It looks like it's an incompatibility between an (older?) BIOS and the newer FLIRC firmwares. The problematic FLIRC actually works fine IN ALL MY OTHER COMPUTERS. I even have another computer that happily uses the newer firmware! (most recently acquired FLIRC) This is what I found: The older firmware FLIRCs (I have 3 out of 5) show this in the dmesg logs (this is from an ACER laptop that accepts the new FLIRC firmware): [ 2.684173] usb 3-1: Product: flirc [ 2.684179] usb 3-1: Manufacturer: flirc.tv [ 3.175146] hid-generic 0003:20A0:0006.0001: hiddev0,hidraw0: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:00:1d.1-1/input0 [ 3.178524] input: flirc.tv flirc Keyboard as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input9 [ 3.240745] input: flirc.tv flirc Consumer Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input10 [ 3.241127] input: flirc.tv flirc System Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input11 [ 3.241493] hid-generic 0003:20A0:0006.0002: input,hidraw1: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-0000:00:1d.1-1/input1 The 2 newer FLIRCs show this: [ 2.657673] usb 3-1: Product: flirc [ 2.657678] usb 3-1: Manufacturer: flirc.tv [ 3.175787] hid-generic 0003:20A0:0006.0001: hiddev0,hidraw0: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:00:1d.1-1/input0 [ 3.181080] input: flirc.tv flirc Keyboard as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input9 [ 3.240721] input: flirc.tv flirc Consumer Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input10 [ 3.241115] input: flirc.tv flirc System Control as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.1/0003:20A0:0006.0002/input/input11 [ 3.241510] hid-generic 0003:20A0:0006.0002: input,hidraw1: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-0000:00:1d.1-1/input1 [ 3.243629] hid-generic 0003:20A0:0006.0003: hiddev1,hidraw2: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:00:1d.1-1/input2 Notice that extra last line? (hiddev1,hidraw2.../input2) all my other computers are happy with that extra device but not that particular one. Other computers have varying dmesg output concerning the recognized device, based on the various BIOSes but this last line is the consistent difference between the new firmware and the older one. Incidentally, the computer with the problem, using an older firmware FLIRC shows this at boot-up: [ 2.910197] usb 2-6: Product: flirc [ 2.910202] usb 2-6: Manufacturer: flirc.tv [ 3.004565] hid-generic 0003:20A0:0006.0001: hiddev0,hidraw0: USB HID v1.11 Device [flirc.tv flirc] on usb-0000:00:04.0-6/input0 [ 3.005672] input: flirc.tv flirc as /devices/pci0000:00/0000:00:04.0/usb2/2-6/2-6:1.1/0003:20A0:0006.0002/input/input5 [ 3.064504] hid-generic 0003:20A0:0006.0002: input,hidraw1: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-0000:00:04.0-6/input1 Notice it doesn't identify the "Keyboard", "Consumer Control" nor the "System Control" devices? but it does recognize input,hidraw1 as "USB HID v1.01 Keyboard". Ok, I hope this helps because I think I'm at the end of what I can contribute here ;-) I guess if no solution is found, I can always swap out an older FLIRC and never upgrade the firmware until this issue is resolved..? Thanks, Daniel P.S. Is it just me but each time I want to log in to this forum, my password isn't recognized and I have to go through the "Forgot password" mechanism. I can then just re-enter the same password again and I am good to go until I log out!?
  5. 1 point
    This is not working, we're messaging hours a part. I'll DM you my private contact info.
  6. 1 point
    ffs! I've been searching for more then 1 hour for an older version of flirc. Because... " [v3.22.4] [gui] Windows driver fixes for gen1 products Does the opposite. Now Flirc software does not work. Says device disconnected BUT ITS NOT! works just fine. So why did I update then, well. I wanted to adjust the input repeat or whats its called but that's impossible now ... so PLZ for the love of GOD dont wipe the net of older version of Flirc. It's always a good idea to have a couple of versions live. So, can I please have, and older version, Unsure on when it stopped working. Haven't updated Flirc for a while. Not sure with generation I have. Mine is see through plastic. Running on Windows 10 latest update. flirc_log.txt
×
×
  • Create New...